summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoost Bremmer2020-04-05 01:06:08 +0200
committerJoost Bremmer2020-04-05 01:06:08 +0200
commitec709fee009f24d33d4792d2f47f684661e20222 (patch)
treecb10a70e0253f5583aafc311d757bc5bb18987cd
parent0e5311ef8e76819264a693159369d8e9d07fae5b (diff)
downloadaur-ec709fee009f24d33d4792d2f47f684661e20222.tar.gz
upgpkg: shortcut-git 0.1.0-1
update c-client pages directory patch
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--shortcut-c-client.patch67
3 files changed, 15 insertions, 60 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4deed33b288d..152a5293170d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = shortcut-git
pkgdesc = A commandline client to list shortcuts
pkgver = 0.1.0
- pkgrel = 2
+ pkgrel = 1
url = https://github.com/mt-empty/shortcut-c-client
arch = x86_64
license = unknown
@@ -11,7 +11,7 @@ pkgbase = shortcut-git
source = shortcut-c-client.patch
sha256sums = SKIP
sha256sums = SKIP
- sha256sums = 3f0af6ac4ffff057a862d2f40a3aac1c83ef5f1a6ce4557275e7d101449f3888
+ sha256sums = 61511fb1b61e7d07e3819d6bae477537ab14d4acd27490ddab5fa1a121822464
pkgname = shortcut-pages-git
pkgdesc = A collections of keyboard shortcuts for Desktop application and websites
diff --git a/PKGBUILD b/PKGBUILD
index 3e2279cc51ec..5e296946a560 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgbase=shortcut-git
pkgname=('shortcut-pages-git' 'shortcut-pages-extra-git' 'shortcut-c-client-git')
pkgver=0.1.0
-pkgrel=2
+pkgrel=1
pkgdesc="A commandline client to list shortcuts"
url="https://github.com/mt-empty/shortcut-c-client"
arch=('x86_64')
@@ -13,7 +13,7 @@ source=("shortcut-pages::git+https://github.com/mt-empty/shortcut-pages.git"
"shortcut-c-client.patch")
sha256sums=('SKIP'
'SKIP'
- '40764c2baf725a7964f5d516fa4217a70aa384ceff74d74506341ce555cdb4b5')
+ '61511fb1b61e7d07e3819d6bae477537ab14d4acd27490ddab5fa1a121822464')
pkgver() {
cd "${srcdir}/shortcut-pages"
diff --git a/shortcut-c-client.patch b/shortcut-c-client.patch
index 8e2d2eacd5e7..f47bbe6f1cee 100644
--- a/shortcut-c-client.patch
+++ b/shortcut-c-client.patch
@@ -1,60 +1,15 @@
Only in old: .git
Only in old: .gitignore
-diff -aur old/makefile new/makefile
---- old/makefile 2020-03-29 23:18:12.952101599 +0200
-+++ new/makefile 2020-03-29 23:22:29.520194912 +0200
-@@ -3,8 +3,9 @@
- DBGFLAG := -g
- CCOBJFLAG := $(CCFLAG) -c
-
--PREFIX = /usr/local
-+PREFIX = /usr/
- DESTDIR =
-+DATADIR = /usr/share
- TARGET = shortcut
-
- REPO = https://github.com/mt-empty/shortcut-pages
-@@ -33,22 +34,22 @@
-
- @echo "Installing"
-
-- @mkdir -p $(DESTDIR)/opt/$(TARGET)
-- @mv pages/ $(DESTDIR)/opt/$(TARGET)
-- @mv $< $(DESTDIR)/opt/$(TARGET)
-- @cp Readme.md $(DESTDIR)/opt/$(TARGET)
-+ @mkdir -p $(DESTDIR)/$(DATADIR)/$(TARGET)
-+ @mv pages/ $(DESTDIR)/$(DATADIR)/$(TARGET)
-+ @mv $< $(DESTDIR)/$(DATADIR)/$(TARGET)
-+ @cp Readme.md $(DESTDIR)/$(DATADIR)/$(TARGET)
-
- @mkdir -p $(DESTDIR)$(PREFIX)/bin
-- @ln -s $(DESTDIR)/opt/$(TARGET)/$(TARGET) $(DESTDIR)$(PREFIX)/bin/$(TARGET)
-+ @ln -s $(DESTDIR)/$(DATADIR)/$(TARGET)/$(TARGET) $(DESTDIR)$(PREFIX)/bin/$(TARGET)
- @echo "All done"
-
- .PHONY: install-extra
- install-extra: install
-- @cp -r shortcut-pages/nonGUI/* $(DESTDIR)/opt/$(TARGET)/pages/
-+ @cp -r shortcut-pages/nonGUI/* $(DESTDIR)/$(DATADIR)/$(TARGET)/pages/
+Only in new: old
+diff -aur old/shortcut.c new/shortcut.c
+--- old/shortcut.c 2020-04-04 23:59:27.301091762 +0200
++++ new/shortcut.c 2020-04-05 00:01:08.758271659 +0200
+@@ -28,7 +28,7 @@
+ #define VERSION "0.1.0"
+ #define BUFFER_SIZE 1000
+-#define PAGES_BASE_DIR "/opt/shortcut/pages/"
++#define PAGES_BASE_DIR "/usr/share/shortcut/pages/"
+ #define PAGES_FILE_EXT ".md"
- .PHONY: uninstall
- uninstall:
- @rm -rf $(DESTDIR)$(PREFIX)/bin/$(TARGET)
-- @rm -rf $(DESTDIR)/opt/$(TARGET)
--# @echo "All done"
-\ No newline at end of file
-+ @rm -rf $(DESTDIR)/$(DATADIR)/$(TARGET)
-+# @echo "All done"
-diff -aur old/shortcut.c new/shortcut.c
---- old/shortcut.c 2020-03-29 23:18:12.952101599 +0200
-+++ new/shortcut.c 2020-03-29 23:23:52.270653011 +0200
-@@ -136,7 +136,7 @@
- // prints shortcut page of a given program
- int getShortcutPage(char *filename)
- {
-- char path[50] = "/opt/shortcut/pages/";
-+ char path[56] = "/usr/share/shortcut/pages/";
- strcat(path, filename);
- strcat(path, ".md");
- // fprintf(stdout, "%s \n", path);
+ #define ANSI_COLOR_RESET_FG "\x1b[39m"