summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJ5lx2015-06-09 17:09:59 +0200
committerJ5lx2015-06-09 17:09:59 +0200
commitec7c1487715b9eeff6d530589f3f2b33e389ee78 (patch)
treefa903e4ccc0f4c486ed70548f87177c908135474
downloadaur-ec7c1487715b9eeff6d530589f3f2b33e389ee78.tar.gz
Initial import
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD28
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4df312397ed6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = ocaml-core_bench
+ pkgdesc = A micro-benchmarking library for ocaml
+ pkgver = 112.17.00
+ pkgrel = 1
+ url = https://github.com/janestreet/core_bench
+ arch = i686
+ arch = x86_64
+ license = unknown
+ makedepends = ocaml-findlib
+ depends = ocaml
+ depends = ocaml-bin_prot
+ depends = camlp4
+ depends = ocaml-comparelib
+ depends = ocaml-core
+ depends = ocaml-fieldslib
+ depends = ocaml-pa_ounit
+ depends = ocaml-sexplib
+ depends = ocaml-textutils
+ options = !strip
+ source = https://ocaml.janestreet.com/ocaml-core/112.17/files/core_bench-112.17.00.tar.gz
+ md5sums = d507304cc31692cf9ba4c7bdf3e9cc25
+
+pkgname = ocaml-core_bench
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..04a00b484d3c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
+
+pkgname=ocaml-core_bench
+pkgver=112.17.00
+pkgrel=1
+license=('unknown')
+arch=('i686' 'x86_64')
+pkgdesc="A micro-benchmarking library for ocaml"
+url="https://github.com/janestreet/core_bench"
+depends=('ocaml' 'ocaml-bin_prot' 'camlp4' 'ocaml-comparelib' 'ocaml-core' 'ocaml-fieldslib' 'ocaml-pa_ounit' 'ocaml-sexplib' 'ocaml-textutils')
+makedepends=('ocaml-findlib')
+source=("https://ocaml.janestreet.com/ocaml-core/$(echo ${pkgver} | grep -Po "^[0-9]+\.[0-9]+")/files/${pkgname#ocaml-}-${pkgver}.tar.gz")
+options=('!strip')
+md5sums=('d507304cc31692cf9ba4c7bdf3e9cc25')
+
+build() {
+ cd "${srcdir}/${pkgname#ocaml-}-${pkgver}"
+ ./configure --prefix /usr
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname#ocaml-}-${pkgver}"
+
+ export OCAMLFIND_DESTDIR="${pkgdir}$(ocamlfind printconf destdir)"
+ mkdir -p "$OCAMLFIND_DESTDIR/stublibs"
+ make install
+}