summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorvitalyr2022-05-19 23:59:34 +0800
committervitalyr2022-05-19 23:59:34 +0800
commiteca7956a0318a2afed4dcb4ed6aa6d0c829c0e48 (patch)
tree5618b319e0887c092531cb7e3be6d13bc908f775
parent108f15542f231ff7deb4ddf29ed29301b829d47c (diff)
downloadaur-eca7956a0318a2afed4dcb4ed6aa6d0c829c0e48.tar.gz
use gcc, for the emacs compiled using gcc is faster (really?)
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD9
2 files changed, 6 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 71d9f72107d7..3b1fd68e79a4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = emacs-native-comp-git-enhanced
pkgdesc = GNU Emacs. Development master branch.
- pkgver = 29.0.50.154541
+ pkgver = 29.0.50.156571
pkgrel = 1
url = http://www.gnu.org/software/emacs/
install = emacs-git.install
@@ -8,9 +8,7 @@ pkgbase = emacs-native-comp-git-enhanced
license = GPL3
makedepends = git
makedepends = mold
- makedepends = clang
- makedepends = llvm
- makedepends = lld
+ makedepends = mold
makedepends = xorgproto
makedepends = libxi
depends = gnutls
diff --git a/PKGBUILD b/PKGBUILD
index 141d0b32c817..a6d10f6dc083 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -38,7 +38,7 @@ USE_ALL_CPU_CORES="YES" # Do you want to use all CPU cores?
CHECK= # Run tests. May fail, this is developement after all.
-CLANG="YES" # Use clang.
+CLANG= # Use clang.
GOLD= # Use the gold linker.
@@ -103,7 +103,7 @@ if [[ $CLI == "YES" ]] ; then
else
pkgname="emacs-native-comp-git-enhanced"
fi
-pkgver=29.0.50.154541
+pkgver=29.0.50.156571
pkgrel=1
pkgdesc="GNU Emacs. Development master branch."
arch=('x86_64')
@@ -140,10 +140,9 @@ if [[ $MOLD == "YES" && ! $CLANG == "YES" ]]; then
# Make sure mold is available in /usr/bin/mold, or
# you could specify another path to mold.
makedepends+=( 'mold' )
- ln -s /usr/bin/mold ./ld
export LD=/usr/bin/mold
- export CFLAGS+=" -B.";
- export CXXFLAGS+=" -B.";
+ export CFLAGS+=" -fuse-ld=gold";
+ export CXXFLAGS+=" -fuse-ld=gold";
fi
if [[ $CLANG == "YES" ]]; then