summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDominic2021-10-28 21:53:12 +0200
committerDominic2021-10-28 21:53:12 +0200
commitecab826e390a5e01666c5d987a4a9532654d1bae (patch)
treec42daee8f63917a8b8291732f12a71ca40fe6c08
downloadaur-ecab826e390a5e01666c5d987a4a9532654d1bae.tar.gz
rlottie 0.2
-rw-r--r--.SRCINFO18
-rw-r--r--0001-add-missing-include.patch10
-rw-r--r--PKGBUILD51
3 files changed, 79 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..16879d0f0e35
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = rlottie
+ pkgdesc = A platform independent standalone library that plays Lottie Animation
+ pkgver = 0.2
+ pkgrel = 1
+ url = https://github.com/Samsung/rlottie
+ arch = x86_64
+ license = Custom
+ makedepends = cmake
+ makedepends = git
+ makedepends = ninja
+ makedepends = patchelf
+ depends = libpng
+ source = https://github.com/Samsung/rlottie/archive/refs/tags/v0.2.tar.gz
+ source = 0001-add-missing-include.patch
+ sha256sums = 030ccbc270f144b4f3519fb3b86e20dd79fb48d5d55e57f950f12bab9b65216a
+ sha256sums = 6dd2d214beecf74347102b0f4481cfc3a4faa5d8a8ac19d4d03a1ddfd0744d00
+
+pkgname = rlottie
diff --git a/0001-add-missing-include.patch b/0001-add-missing-include.patch
new file mode 100644
index 000000000000..e276ddf08409
--- /dev/null
+++ b/0001-add-missing-include.patch
@@ -0,0 +1,10 @@
+--- src/vector/vrle.cpp 2021-10-28 21:47:37.898062662 +0200
++++ src/vector/vrle.cpp 2021-10-28 21:47:48.154677016 +0200
+@@ -27,6 +27,7 @@
+ #include <array>
+ #include <cstdlib>
+ #include <cstring>
++#include <limits>
+ #include <vector>
+ #include "vdebug.h"
+ #include "vglobal.h"
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..87f0874cf065
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# -*- mode: Shell-script; eval: (setq indent-tabs-mode 't); eval: (setq tab-width 4) -*-
+# Maintainer: Dominic Meiser <git at msrd0 dot de>
+# Contributor: BluePeril <blueperil (at) blueperil _dot_ de>
+
+pkgname=rlottie
+pkgver=0.2
+pkgrel=1
+pkgdesc='A platform independent standalone library that plays Lottie Animation'
+arch=('x86_64')
+url='https://github.com/Samsung/rlottie'
+license=('Custom')
+makedepends=('cmake' 'git' 'ninja' 'patchelf')
+depends=('libpng')
+source=(
+ "https://github.com/Samsung/rlottie/archive/refs/tags/v$pkgver.tar.gz"
+ "0001-add-missing-include.patch"
+)
+sha256sums=('030ccbc270f144b4f3519fb3b86e20dd79fb48d5d55e57f950f12bab9b65216a'
+ '6dd2d214beecf74347102b0f4481cfc3a4faa5d8a8ac19d4d03a1ddfd0744d00')
+
+prepare() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ ls -l src/lottie/lottieparser.cpp
+ patch --forward --strip=0 --input="$srcdir/0001-add-missing-include.patch"
+ ls -l src/lottie/lottieparser.cpp
+ mkdir -p build
+}
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver/build"
+
+ cmake .. \
+ -G Ninja \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release
+ ninja
+ patchelf --remove-rpath example/lottie2gif
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver/build"
+
+ DESTDIR="$pkgdir" ninja install
+ install -Dm755 example/lottie2gif "$pkgdir/usr/bin/lottie2gif"
+
+ install -Dm644 "../COPYING" "$pkgdir/usr/share/licenses/$pkgname/COPYING"
+ for _file in ../licenses/*; do
+ install -Dm644 $_file "$pkgdir/usr/share/licenses/$pkgname/licenses/$(basename $_file)"
+ done
+}