summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew Stubbs2017-02-22 11:11:12 +0000
committerAndrew Stubbs2017-02-22 11:11:12 +0000
commitecd068dd3d9e78932c9c1f105c877ddf0ac7c0d1 (patch)
treeddd858e32c220a9eb92eb2d45667d5477c2f76ba
parente43cd57b3f39f2df84c509f7254c68c7924d78c6 (diff)
downloadaur-ecd068dd3d9e78932c9c1f105c877ddf0ac7c0d1.tar.gz
Bump 1.2.0
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD25
2 files changed, 19 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 54e61a66583e..781b1f0676f5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,17 @@
# Generated by mksrcinfo v8
-# Fri Jul 8 09:57:58 UTC 2016
+# Wed Feb 22 11:09:56 UTC 2017
pkgbase = mimic-git
pkgdesc = Text-to-speech voice synthesis from the Mycroft project.
- pkgver = r167.0513650
+ pkgver = 1.2.0.r0.eb4613e
pkgrel = 1
url = https://mimic.mycroft.ai/
arch = x86_64
arch = i686
license = custom
makedepends = git
+ makedepends = libtool
+ makedepends = autoconf
+ makedepends = automake
depends = alsa-lib
provides = mimic
conflicts = mimic
diff --git a/PKGBUILD b/PKGBUILD
index 6770aa736e64..38a2aacc5cdc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Andrew Stubbs <andrew.stubbs@gmail.com>
pkgname=mimic-git
-pkgver=r167.0513650
+pkgver=1.2.0.r0.eb4613e
pkgrel=1
pkgdesc="Text-to-speech voice synthesis from the Mycroft project."
arch=(x86_64 i686)
@@ -8,7 +8,7 @@ url="https://mimic.mycroft.ai/"
license=('custom')
groups=()
depends=(alsa-lib)
-makedepends=('git')
+makedepends=('git' 'libtool' 'autoconf' 'automake')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
replaces=()
@@ -26,10 +26,10 @@ pkgver() {
cd "$srcdir/${pkgname%-git}"
# Git, tags available
-# printf "%s" "$(git describe --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
+ printf "%s" "$(git describe --tags --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
# Git, no tags available
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+# printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build() {
@@ -38,15 +38,18 @@ build() {
unset BUILDDIR
cd "$srcdir/${pkgname%-git}"
- #./configure --prefix=/usr --with-audio=pulseaudio
- ./configure --prefix=/usr --with-audio=alsa
- make
+ ./autogen.sh
+ ./configure --prefix=/usr
+
+ #make
+ # Temporary workaround for https://github.com/MycroftAI/mimic/issues/95
+ make CFLAGS='-D_DEFAULT_SOURCE -O2'
}
-#check() {
-# cd "$srcdir/${pkgname%-git}"
-# make -k test
-#}
+check() {
+ cd "$srcdir/${pkgname%-git}"
+ make -k check
+}
package() {
cd "$srcdir/${pkgname%-git}"