summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarsten Teibes2017-07-05 22:32:13 +0200
committerCarsten Teibes2017-07-05 22:32:13 +0200
commitecd7cb381c0204649621d888aa202ed17969da36 (patch)
tree90e207ce387fe9d2d37d4db1d42f12c21b7d2728
parent0165f9a211d85f045db9dd33b821e2abd89991ed (diff)
downloadaur-ecd7cb381c0204649621d888aa202ed17969da36.tar.gz
[upd] use cmake, [fix] game library path
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD18
2 files changed, 15 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1f5acae0aa64..df381f8e8817 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = yamagi-quake2-rogue-git
pkgdesc = Quake II - Mission Pack 2 ('Ground Zero') for yamagi-quake2 (development version)
- pkgver = 2.01.r0.gf749f68
+ pkgver = 2.04.r1.g891e75c
pkgrel = 1
url = http://www.yamagi.org/quake2/
install = yamagi-quake2-rogue.install
@@ -8,6 +8,7 @@ pkgbase = yamagi-quake2-rogue-git
arch = x86_64
license = GPL
license = custom
+ makedepends = cmake
depends = sh
depends = yamagi-quake2
provides = yamagi-quake2-rogue
diff --git a/PKGBUILD b/PKGBUILD
index f11768e4e850..1e127b801743 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,14 @@
# Maintainer: carstene1ns <arch carsten-teibes de> - http://git.io/ctPKG
pkgname=yamagi-quake2-rogue-git
-pkgver=2.01.r0.gf749f68
+pkgver=2.04.r1.g891e75c
pkgrel=1
arch=('i686' 'x86_64')
pkgdesc="Quake II - Mission Pack 2 ('Ground Zero') for yamagi-quake2 (development version)"
url="http://www.yamagi.org/quake2/"
license=('GPL' 'custom')
depends=('sh' 'yamagi-quake2')
+makedepends=('cmake')
provides=("${pkgname%-*}")
conflicts=("${pkgname%-*}")
install=${pkgname%-*}.install
@@ -23,19 +24,26 @@ pkgver() {
git describe --long --tags | sed 's/^ROGUE_//;s/_/./;s/\([^-]*-g\)/r\1/;s/-/./g'
}
+prepare() {
+ rm -rf build
+ mkdir -p build
+}
+
build() {
- make -C ${pkgname%-*}
+ cd build
+ cmake ../${pkgname%-*} -DCMAKE_BUILD_TYPE=Release
+ make
}
package() {
+ # game library
+ install -Dm644 build/Release/game.so "$pkgdir"/usr/lib/yamagi-quake2/rogue/game.so
+
cd ${pkgname%-*}
# game launcher
install -Dm755 ../${pkgname%-*}.sh "$pkgdir"/usr/bin/${pkgname%-*}
- # game library
- install -Dm644 release/game.so "$pkgdir"/usr/share/yamagi-quake2/rogue/game.so
-
# doc
install -Dm644 README "$pkgdir"/usr/share/doc/${pkgname%-*}/README