summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNarrat2021-05-07 23:51:49 +0200
committerNarrat2021-05-07 23:51:49 +0200
commited7704e5605a587457376781eb361fdee5a2eab1 (patch)
treec49257503548dcdf6edbd6672438a7da8d5ff3ed
parent7101765a8eb4d48838476206ad2f76d701d78072 (diff)
downloadaur-ed7704e5605a587457376781eb361fdee5a2eab1.tar.gz
pyhn: Drop python2 build
As python2 is EOLed and more and more deps are dropped from the repos. And the building steps had a error anyway and as no one noticed it...
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD26
2 files changed, 11 insertions, 34 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d9c72e7820d3..8735e2c8efe7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,24 +5,11 @@ pkgbase = pyhn
url = https://pypi.python.org/pypi/pyhn/
arch = any
license = AGPL3
- makedepends = python-urwid
- makedepends = python-beautifulsoup4
- makedepends = python-isit
- makedepends = python2-urwid
- makedepends = python2-beautifulsoup4
- makedepends = python2-isit
- source = https://pypi.io/packages/source/p/pyhn/pyhn-0.3.11.tar.gz
- md5sums = e742e4cc9b29bc4fdcccbbd94d83a486
-
-pkgname = pyhn
- pkgdesc = Hacker News command line client (Python3.x)
depends = python-urwid
depends = python-beautifulsoup4
depends = python-isit
+ source = https://pypi.io/packages/source/p/pyhn/pyhn-0.3.11.tar.gz
+ md5sums = e742e4cc9b29bc4fdcccbbd94d83a486
-pkgname = pyhn2
- pkgdesc = Hacker News command line client (Python2.x)
- depends = python2-urwid
- depends = python2-beautifulsoup4
- depends = python2-isit
+pkgname = pyhn
diff --git a/PKGBUILD b/PKGBUILD
index 054dc4fb4f89..876693f70e8a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,34 +2,24 @@
# Contributor: alejandrogomez <alejandroogomez@gmail.com>
pkgbase=pyhn
-pkgname=('pyhn' 'pyhn2')
+pkgname=pyhn
pkgver=0.3.11
pkgrel=1
pkgdesc="Hacker News command line client"
arch=('any')
url="https://pypi.python.org/pypi/pyhn/"
license=('AGPL3')
-makedepends=('python-urwid' 'python-beautifulsoup4' 'python-isit')
-makedepends+=('python2-urwid' 'python2-beautifulsoup4' 'python2-isit')
+depends=('python-urwid' 'python-beautifulsoup4' 'python-isit')
source=(https://pypi.io/packages/source/p/$pkgbase/$pkgbase-$pkgver.tar.gz)
md5sums=('e742e4cc9b29bc4fdcccbbd94d83a486')
-package_pyhn() {
- pkgdesc+=" (Python3.x)"
- depends=('python-urwid' 'python-beautifulsoup4' 'python-isit')
-
- cd "$srcdir/$pkgbase-$pkgver"
-
- python setup.py install --root="$pkgdir/" --prefix=/usr --optimize=1
+build() {
+ cd ${pkgbase}-${pkgver}
+ python setup.py build
}
-package_pyhn2() {
- pkgdesc+=" (Python2.x)"
- depends=('python2-urwid' 'python2-beautifulsoup4' 'python2-isit')
-
- cd "$srcdir/$pkgbase-$pkgver"
-
- python setup.py install --root="$pkgdir/" --prefix=/usr --optimize=1
- mv $pkgdir/usr/bin/$pkgbase $pkgdir/usr/bin/${pkgbase}2
+package() {
+ cd ${pkgbase}-${pkgver}
+ python setup.py install --root="$pkgdir/" --prefix=/usr --optimize=1 --skip-build
}