summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDennis Stengele2019-05-19 14:29:02 +0200
committerDennis Stengele2019-05-19 14:29:02 +0200
commited8743ec60b7dc003f0706db0c00c6f474644092 (patch)
treeaeaa0bf44dce772c98a54855636742a2d066d2e5
parent2a2479e5fcc7a494eab251f683319099e4a6831a (diff)
downloadaur-ed8743ec60b7dc003f0706db0c00c6f474644092.tar.gz
Fix Go ignoring the needed modules for building
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD3
2 files changed, 3 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ecd43c3dba76..4fae5b314820 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = beehive
pkgdesc = A flexible event and agent system with lots of bees
pkgver = 0.3.1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/muesli/beehive
install = beehive.install
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 3248e2a54665..edd0dcb4083b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=beehive
pkgver=0.3.1
-pkgrel=1
+pkgrel=2
pkgdesc="A flexible event and agent system with lots of bees"
arch=('x86_64' 'i686')
url="https://github.com/muesli/beehive"
@@ -21,6 +21,7 @@ build() {
mkdir -p gopath/src/github.com/muesli
ln -rTsf $pkgname-$pkgver gopath/src/github.com/muesli/$pkgname
export GOPATH="$srcdir"/gopath
+ export GO111MODULE=on
cd gopath/src/github.com/muesli/$pkgname
make
}