summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorButui Hu2020-12-15 14:14:13 +0800
committerButui Hu2020-12-15 14:14:13 +0800
commiteda3857a7a714fd3abca0c3ddae9c1f4f0753d7f (patch)
tree52724219288e5c083e39a1fa2a55ad4fc19aa9ac
downloadaur-eda3857a7a714fd3abca0c3ddae9c1f4f0753d7f.tar.gz
first commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD33
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4e6310c525da
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-pylibjpeg
+ pkgdesc = A Python framework for decoding JPEG images, with a focus on supporting pydicom
+ pkgver = 1.1.1
+ pkgrel = 1
+ url = https://github.com/pydicom/pylibjpeg
+ arch = any
+ license = MIT
+ checkdepends = python-pytest
+ makedepends = python-setuptools
+ depends = python-pylibjpeg-openjpeg
+ source = python-pylibjpeg-1.1.1.tar.gz::https://github.com/pydicom/pylibjpeg/archive/v1.1.1.tar.gz
+ sha512sums = ac62f66dc7e74e8e8c7c781fb370a7869058efd28ebdbf7a75f569c3a82d543d5d7b3405262ffca4a134c92dfe1e65c2c03c510e34bd2d7982a51c7b5ce8e113
+
+pkgname = python-pylibjpeg
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e98d9981514d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Butui Hu <hot123tea123@gmail.com>
+
+_pkgname=pylibjpeg
+pkgname=python-pylibjpeg
+pkgver=1.1.1
+pkgrel=1
+pkgdesc='A Python framework for decoding JPEG images, with a focus on supporting pydicom'
+arch=(any)
+url='https://github.com/pydicom/pylibjpeg'
+license=(MIT)
+depends=(
+ python-pylibjpeg-openjpeg
+)
+makedepends=(
+ python-setuptools
+)
+checkdepends=(
+ python-pytest
+)
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/pydicom/pylibjpeg/archive/v${pkgver}.tar.gz")
+sha512sums=('ac62f66dc7e74e8e8c7c781fb370a7869058efd28ebdbf7a75f569c3a82d543d5d7b3405262ffca4a134c92dfe1e65c2c03c510e34bd2d7982a51c7b5ce8e113')
+
+build() {
+ cd "${_pkgname}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "${_pkgname}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ install -Dm644 "LICENCE.txt" -t "${pkgdir}/usr/share/licenses/${pkgname}"
+}
+# vim:set ts=2 sw=2 et: