summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2021-10-30 15:39:14 -0600
committerMark Wagie2021-10-30 15:39:14 -0600
commitedb220d9089f25807c1c5f5fe0dc4c9264d4862b (patch)
tree02f9e9c73d7b5fd21b4cfab4aa02f5a4dff682d1
parentc74ed424039ef5aa0ce73ece50f13af3e0c9ab21 (diff)
downloadaur-edb220d9089f25807c1c5f5fe0dc4c9264d4862b.tar.gz
use signed commit
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD17
2 files changed, 17 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7a2325565ca3..46f593c16629 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,12 @@
pkgbase = meteo-gtk
pkgdesc = A forecast application using OpenWeatherMap API
pkgver = 0.9.9
- pkgrel = 1
+ pkgrel = 2
url = https://gitlab.com/bitseater/meteo
arch = x86_64
license = GPL3
checkdepends = appstream
+ makedepends = git
makedepends = meson
makedepends = vala
depends = gtk3
@@ -13,7 +14,8 @@ pkgbase = meteo-gtk
depends = webkit2gtk
provides = meteo
conflicts = meteo
- source = meteo-gtk-0.9.9.tar.gz::https://gitlab.com/bitseater/meteo/-/archive/0.9.9/meteo-0.9.9.tar.gz
- sha256sums = dea9dd25da3d792d0713a3761b5c43ca8dad54a4eb17a8d688212a9acfafd855
+ source = git+https://gitlab.com/bitseater/meteo.git#commit=03a2741eff4f9446e7d8b023019d31e563207f6f?signed
+ validpgpkeys = 900E41F44EFF4B6D696EB80AE6BDC743AED36483
+ sha256sums = SKIP
pkgname = meteo-gtk
diff --git a/PKGBUILD b/PKGBUILD
index f990765b1aa8..c9d7f6efc94e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,28 @@
# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
pkgname=meteo-gtk
pkgver=0.9.9
-pkgrel=1
+pkgrel=2
pkgdesc="A forecast application using OpenWeatherMap API"
arch=('x86_64')
url="https://gitlab.com/bitseater/meteo"
license=('GPL3')
depends=('gtk3' 'libappindicator-gtk3' 'webkit2gtk')
-makedepends=('meson' 'vala')
+makedepends=('git' 'meson' 'vala')
checkdepends=('appstream')
provides=("${pkgname%-gtk}")
conflicts=("${pkgname%-gtk}")
-source=("$pkgname-$pkgver.tar.gz::$url/-/archive/$pkgver/${pkgname%-gtk}-$pkgver.tar.gz")
-sha256sums=('dea9dd25da3d792d0713a3761b5c43ca8dad54a4eb17a8d688212a9acfafd855')
+_commit=03a2741eff4f9446e7d8b023019d31e563207f6f
+source=("git+https://gitlab.com/bitseater/meteo.git#commit=$_commit?signed")
+sha256sums=('SKIP')
+validpgpkeys=('900E41F44EFF4B6D696EB80AE6BDC743AED36483') # Carlos Suárez <bitseater@gmail.com>
+
+pkgver() {
+ cd "$srcdir/${pkgname%-gtk}"
+ git describe --tags | sed 's/-/+/g'
+}
build() {
- arch-meson "${pkgname%-gtk}-$pkgver" build
+ arch-meson "${pkgname%-gtk}" build
meson compile -C build
}