summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorohnonot2020-02-07 20:42:36 +0200
committerohnonot2020-02-07 20:42:36 +0200
commitedcd36d6d3b0aa4878e3f3519a5cd9681cfe7e2d (patch)
treef9bec3b551afc00b3152dee9670271333048801e
downloadaur-edcd36d6d3b0aa4878e3f3519a5cd9681cfe7e2d.tar.gz
First commit
-rw-r--r--.SRCINFO27
-rw-r--r--.gitignore8
-rw-r--r--PKGBUILD65
-rw-r--r--conky.h.patch10
4 files changed, 110 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e1be75f490ef
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = conky19
+ pkgdesc = An advanced system monitor for X based on torsmo - minimal configuration
+ pkgver = 1.9.0
+ pkgrel = 10
+ url = https://github.com/brndnmtthws/conky/
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = pkgconfig
+ makedepends = docbook2x
+ makedepends = docbook-xml
+ makedepends = docbook-xsl
+ depends = libxml2
+ depends = curl
+ depends = cairo
+ depends = libxft
+ depends = glib2
+ depends = libxdamage
+ depends = imlib2
+ provides = conky
+ source = conky-1.9.0.tar.gz::https://github.com/brndnmtthws/conky/archive/1.9.0.tar.gz
+ source = conky.h.patch
+ md5sums = b13f2c7d52e18d94bfbfcd5157406db7
+ md5sums = 3a4ebcc2e18685302945944f7bc0c87b
+
+pkgname = conky19
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e50d7f964192
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+*
+!.gitignore
+!PKGBUILD
+!.SRCINFO
+!*.patch
+!*.diff
+!*.install
+!*.service
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f88376133cdf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,65 @@
+# Maintainer: ondoho <ohnonot-github@posteo.de>
+# Contributor: Jon Wilson <bugs@pandorica.net>
+# Contributor: Spyros Stathopoulos <foucault.online[at]gmail[dot]com>
+# Contributor: Andrwe Lord Weber <lord-weber-andrwe [at] andrwe [dot] org>
+# Contributor: Giovanni Scafora <giovanni@archlinux.org>
+# Contributor: James Rayner <james@archlinux.org>
+# Contributor: Partha Chowdhury <kira.laucas@gmail.com>
+
+pkgname=conky19
+_pkgname=conky
+pkgver=1.9.0
+pkgrel=10
+pkgdesc="An advanced system monitor for X based on torsmo - minimal configuration"
+arch=('i686' 'x86_64')
+url="https://github.com/brndnmtthws/conky/"
+license=('GPL3')
+provides=('conky')
+depends=('libxml2' 'curl' 'cairo' 'libxft' 'glib2' 'libxdamage' 'imlib2')
+makedepends=('pkgconfig' 'docbook2x' 'docbook-xml' 'docbook-xsl')
+source=("${_pkgname}-${pkgver}.tar.gz::https://github.com/brndnmtthws/${_pkgname}/archive/${pkgver}.tar.gz" "conky.h.patch")
+md5sums=('b13f2c7d52e18d94bfbfcd5157406db7' '3a4ebcc2e18685302945944f7bc0c87b')
+
+prepare() {
+ cd ${srcdir}/${_pkgname}-${pkgver}
+ sed -i '/#include <curl\/types.h>/d' ${srcdir}/${_pkgname}-${pkgver}/src/ccurl_thread.c
+ # use "conky19" instead of "conky", so that this version can coexist with normal conky.
+ grep -Irlm1 \${sysconfdir}/conky | while read file; do sed -i "s#\${sysconfdir}/conky#\${sysconfdir}/${pkgname}#g" "$file"; done
+ grep -Irlm1 etc/conky.conf | while read file; do sed -i "s#etc/conky#etc/${pkgname}#g" "$file"; done
+ cd src
+ patch -i ../../conky.h.patch
+}
+
+build() {
+ cd ${srcdir}/${_pkgname}-${pkgver}
+ ./autogen.sh
+ CPPFLAGS="${CXXFLAGS}" LIBS="${LDFLAGS}" ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --disable-wlan \
+ --disable-rss \
+ --disable-ibm \
+ --enable-imlib2 \
+ --disable-lua \
+ --disable-lua-cairo \
+ --disable-lua-imlib2 \
+ --disable-nvidia \
+ --disable-ncurses \
+ --disable-hddtemp \
+ --disable-apcupsd \
+ --disable-math \
+ --disable-mmpd \
+ --disable-moc \
+ --disable-argb \
+ --disable-lua \
+ --disable-alsa \
+ --program-suffix=19
+ make
+}
+
+package() {
+ cd ${srcdir}/${_pkgname}-${pkgver}
+ make DESTDIR=${pkgdir} install
+ install -D -m644 COPYING ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+ install -D -m644 extras/vim/syntax/conkyrc.vim "${pkgdir}"/usr/share/vim/vimfiles/syntax/${pkgname}rc.vim
+ install -D -m644 extras/vim/ftdetect/conkyrc.vim "${pkgdir}"/usr/share/vim/vimfiles/ftdetect/${pkgname}rc.vim
+}
diff --git a/conky.h.patch b/conky.h.patch
new file mode 100644
index 000000000000..5bf2295e42a6
--- /dev/null
+++ b/conky.h.patch
@@ -0,0 +1,10 @@
+--- conky.h 2020-02-07 17:05:54.464384995 +0200
++++ conky.h.new 2020-02-07 17:06:08.524159777 +0200
+@@ -35,6 +35,7 @@
+ #include "common.h" /* at least for struct dns_data */
+ #include <sys/utsname.h> /* struct uname_s */
+ #include <arpa/inet.h>
++#include <stdbool.h>
+
+ #if defined(HAS_MCHECK_H)
+ #include <mcheck.h>