summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander F. Rødseth2019-06-03 13:46:09 +0200
committerAlexander F. Rødseth2019-06-03 13:46:09 +0200
commitedd6a9ed830b484945144e0f26b09ab7abad9fb6 (patch)
tree249af5415b8d8cdb064e53fff0d046be0e0abb66
downloadaur-edd6a9ed830b484945144e0f26b09ab7abad9fb6.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD27
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..377cb7d13e3e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Mon Jun 3 11:45:59 UTC 2019
+pkgbase = botsay
+ pkgdesc = Like cowsay, but with randomly generated ASCII robots
+ pkgver = 1.0.1
+ pkgrel = 1
+ url = https://github.com/xyproto/botsay
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ makedepends = go
+ source = git+https://github.com/xyproto/botsay#tag=v1.0.1
+ md5sums = SKIP
+
+pkgname = botsay
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..beae5cd6697a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Alexander F. Rødseth <xyproto@archlinux.org>
+
+pkgname=botsay
+pkgver=1.0.1
+pkgrel=1
+pkgdesc='Like cowsay, but with randomly generated ASCII robots'
+arch=(x86_64)
+url='https://github.com/xyproto/botsay'
+license=(MIT)
+makedepends=(git go)
+source=("git+$url#tag=v$pkgver")
+md5sums=('SKIP')
+
+build() {
+ cd $pkgname
+
+ go build -buildmode=pie -gccgoflags="-s -w $LDFLAGS"
+}
+
+package() {
+ cd "$pkgname"
+
+ install -Dm755 "$pkgname" "$pkgdir/usr/bin/$pkgname"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+# vim: ts=2 sw=2 et: