summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJacob Mourelos2016-10-17 21:25:33 +0200
committerJacob Mourelos2016-10-17 21:25:33 +0200
commitee2b545e759fd8b0dfbb594189e0eb376487bc87 (patch)
treea027d8ee37404a6aaa2ba1243aa9c874ec04083a
downloadaur-ee2b545e759fd8b0dfbb594189e0eb376487bc87.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD22
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..017ed2c89461
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = doconv
+ pkgdesc = A tool for document file format conversion
+ pkgver = 0.1.6
+ pkgrel = 1
+ url = https://github.com/jmourelos/doconv
+ arch = any
+ license = BSD
+ makedepends = python2-setuptools
+ depends = python2
+ depends = python2-networkx
+ depends = python2-stevedore
+ depends = python2-lxml
+ optdepends = asciidoc
+ source = https://pypi.python.org/packages/source/d/doconv/doconv-0.1.6.tar.gz
+ md5sums = dd78e24c650f1b0a5352b78c784d89c6
+
+pkgname = doconv
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e4d8835a39a3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Jacob Mourelos <jacob.mourelos@gmail.com>
+
+pkgname=doconv
+pkgver=0.1.6
+pkgrel=1
+pkgdesc='A tool for document file format conversion'
+arch=('any')
+url='https://github.com/jmourelos/doconv'
+license=('BSD')
+depends=('python2' 'python2-networkx' 'python2-stevedore' 'python2-lxml')
+optdepends=('asciidoc')
+makedepends=('python2-setuptools')
+
+source=("https://pypi.python.org/packages/source/d/doconv/${pkgname}-${pkgver}.tar.gz")
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ python2 setup.py -q install --root="${pkgdir}" --optimize=1
+}
+
+md5sums=('dd78e24c650f1b0a5352b78c784d89c6')