summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorZhuoyun Wei2015-04-08 12:01:45 +0800
committerZhuoyun Wei2015-04-08 12:01:45 +0800
commitee9e832d52eef3f4fd3b72fb6e5b5ca1665f4b77 (patch)
tree6bfcfbf61321466bdc3258d18c7e307b776657da
downloadaur-ee9e832d52eef3f4fd3b72fb6e5b5ca1665f4b77.tar.gz
Add spdylay
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD31
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f6c5f8bfed43
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = spdylay
+ pkgdesc = The experimental SPDY protocol version 2, 3 and 3.1 implementation in C
+ pkgver = 1.3.2
+ pkgrel = 1
+ url = http://tatsuhiro-t.github.io/spdylay/
+ arch = i686
+ arch = x86_64
+ license = MIT
+ depends = libevent
+ depends = libxml2
+ depends = openssl
+ depends = zlib
+ backup = etc/shrpx/shrpx.conf
+ source = https://github.com/tatsuhiro-t/spdylay/releases/download/v1.3.2/spdylay-1.3.2.tar.gz
+ sha256sums = 7b435d477ed5ecf74959e9c0ef357212bb75e7b97cdbaceba8d1d64c3c4c6e90
+
+pkgname = spdylay
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0862b3a89931
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Zhuoyun Wei <wzyboy@wzyboy.org>
+# Contributor: Dave Reisner <d@falconindy.com>
+
+pkgname=spdylay
+pkgver=1.3.2
+_pkgver=v1.3.2
+pkgrel=1
+pkgdesc="The experimental SPDY protocol version 2, 3 and 3.1 implementation in C"
+arch=('i686' 'x86_64')
+url="http://tatsuhiro-t.github.io/spdylay/"
+license=('MIT')
+depends=('libevent' 'libxml2' 'openssl' 'zlib')
+source=("https://github.com/tatsuhiro-t/spdylay/releases/download/${_pkgver}/spdylay-${pkgver}.tar.gz")
+backup=('etc/shrpx/shrpx.conf')
+sha256sums=('7b435d477ed5ecf74959e9c0ef357212bb75e7b97cdbaceba8d1d64c3c4c6e90')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ ./configure --prefix=/usr
+
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ make DESTDIR="$pkgdir" install
+ install -Dm644 shrpx.conf.sample "$pkgdir/etc/shrpx/shrpx.conf"
+ install -Dm644 COPYING "$pkgdir/usr/share/licenses/spdylay/COPYING"
+}