summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJaroslav Lichtblau2014-11-28 20:17:14 +0100
committerJaroslav Lichtblau2014-11-28 20:17:14 +0100
commiteea217b6c4c9c14efd44274d94c4e54cd82527fa (patch)
treef7de208b7258474bd88cbdf1f9da331763d63dd4
downloadaur-eea217b6c4c9c14efd44274d94c4e54cd82527fa.tar.gz
Initial PKGBUILD status as of 28.11.2014
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD33
-rw-r--r--neonview.desktop8
-rw-r--r--neonview.install5
4 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d4c6748eae83
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = neonview
+ pkgdesc = Free, lightweight image viewer
+ pkgver = 0.8.2
+ pkgrel = 1
+ url = http://www.tuxarena.com/intro/neonview.php
+ install = neonview.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = desktop-file-utils
+ depends = gtk3
+ source = http://www.tuxarena.com/intro/files/neonview-0.8.2-src.tar.gz
+ source = neonview.desktop
+ sha256sums = f48fb09dabeb1ab1c348e5409d3cf84a4054f0838c5b2f2dabccc9115f114e46
+ sha256sums = b858e4e69883f1f675de69bdb22c271976ca64b5bf77a9f746629fada4a97ab8
+
+pkgname = neonview
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2d98f0b5bd93
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Jaroslav Lichtblau <dragonlord@aur.archlinux.org>
+
+pkgname=neonview
+pkgver=0.8.2
+pkgrel=1
+pkgdesc='Free, lightweight image viewer'
+arch=('i686' 'x86_64')
+url='http://www.tuxarena.com/intro/neonview.php'
+license=('GPL')
+depends=('desktop-file-utils' 'gtk3')
+install=$pkgname.install
+source=(http://www.tuxarena.com/intro/files/${pkgname}-${pkgver}-src.tar.gz \
+ $pkgname.desktop)
+sha256sums=('f48fb09dabeb1ab1c348e5409d3cf84a4054f0838c5b2f2dabccc9115f114e46'
+ 'b858e4e69883f1f675de69bdb22c271976ca64b5bf77a9f746629fada4a97ab8')
+
+build() {
+ cd ${pkgname}-${pkgver}-src
+
+ make
+}
+
+package() {
+ cd ${pkgname}-${pkgver}-src
+
+ install -D -m755 $pkgname ${pkgdir}/usr/bin/$pkgname
+
+#.desktop file + icon
+ install -D -m644 ${srcdir}/$pkgname.desktop \
+ ${pkgdir}/usr/share/applications/$pkgname.desktop
+# install -D -m644 ${srcdir}/${pkgname}-${pkgver}-src/icon.png \
+# ${pkgdir}/usr/share/pixmaps/$pkgname.png
+}
diff --git a/neonview.desktop b/neonview.desktop
new file mode 100644
index 000000000000..a3409f384d86
--- /dev/null
+++ b/neonview.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Name=Neonview
+Exec=neonview
+Comment=Lightweight image viewer
+Terminal=false
+Type=Application
+Categories=Graphics;
+Icon=neonview \ No newline at end of file
diff --git a/neonview.install b/neonview.install
new file mode 100644
index 000000000000..464b237a2ad3
--- /dev/null
+++ b/neonview.install
@@ -0,0 +1,5 @@
+post_install() {
+ echo -n "Updating desktop database ..."
+ update-desktop-database -q
+ echo " done."
+}