summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGabriel-Andrew Pollo-Guilbert2020-06-15 19:36:53 -0400
committerGabriel-Andrew Pollo-Guilbert2020-06-15 19:36:53 -0400
commiteec6741b8a40c340c0102f40a5df75fb9add0c4f (patch)
treec3ca66d8fad2acb555e2dfd1b2d3508da402cca8
downloadaur-eec6741b8a40c340c0102f40a5df75fb9add0c4f.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD47
-rw-r--r--tagscanner.sh6
3 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1a8d304e2df4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = tagscanner
+ pkgdesc = Powerful tool for organizing and managing your music collection
+ pkgver = 6.1.4
+ pkgrel = 1
+ url = https://www.xdlab.ru/en/
+ arch = x86_64
+ license = custom
+ depends = wine
+ source = tagscanner.sh
+ md5sums = 2a07e489f02b4897ff10f818309101d7
+ source_x86_64 = https://www.xdlab.ru/files/tagscan-6.1.4_x64.zip
+ md5sums_x86_64 = 6d63a2fda159a314f1a11a712f2c8ff7
+
+pkgname = tagscanner
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3cf45f9b40a7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: Gabriel-Andrew Pollo-Guilbert <gabrielpolloguilbert@gmail.com>
+#
+# You can define $TAGSCANNER_WINEPREFIX environment variable to hardcode the $WINEPREFIX
+# of wine running TagScanner, the is default '~/.wine-tagscanner'.
+
+pkgname=tagscanner
+pkgver=6.1.4
+pkgrel=1
+pkgdesc='Powerful tool for organizing and managing your music collection'
+arch=('x86_64')
+url='https://www.xdlab.ru/en/'
+license=('custom')
+depends=('wine')
+
+source=('tagscanner.sh')
+md5sums=('2a07e489f02b4897ff10f818309101d7')
+
+source_i686=("https://www.xdlab.ru/files/tagscan-${pkgver}.zip")
+md5sums_i686=('f2059adbcab6f0883460a87f9b60094e')
+
+source_x86_64=("https://www.xdlab.ru/files/tagscan-${pkgver}_x64.zip")
+md5sums_x86_64=('6d63a2fda159a314f1a11a712f2c8ff7')
+
+package() {
+ mkdir -p "${pkgdir}/opt/tagscanner/"
+ cp -r "${srcdir}/"* "${pkgdir}/opt/tagscanner/"
+ rm -f "${pkgdir}/opt/tagscanner/tagscan-${pkgver}_x64.zip"
+ rm -f "${pkgdir}/opt/tagscanner/tagscan-${pkgver}.zip"
+
+ mkdir -p "${pkgdir}/usr/bin/"
+ install -Dm755 "${srcdir}/tagscanner.sh" "${pkgdir}/usr/bin/tagscanner"
+
+ if [[ "$arch" == 'i686' ]]; then
+ sed -i 's#${REPLACE_WINEARCH}#win32#g' "${pkgdir}/usr/bin/tagscanner"
+ elif [[ "$arch" == 'x86_64' ]]; then
+ sed -i 's#${REPLACE_WINEARCH}#win64#g' "${pkgdir}/usr/bin/tagscanner"
+ else
+ echo "error: unsupported architecture '$arch'"
+ exit 1
+ fi
+
+ if [[ -z "$TAGSCANNER_WINEPREFIX" ]]; then
+ sed -i "s#\${REPLACE_WINEPREFIX}#~/.wine-tagscanner#g" "${pkgdir}/usr/bin/tagscanner"
+ else
+ sed -i "s#\${REPLACE_WINEPREFIX}#${TAGSCANNER_WINEPREFIX}#g" "${pkgdir}/usr/bin/tagscanner"
+ fi
+}
diff --git a/tagscanner.sh b/tagscanner.sh
new file mode 100644
index 000000000000..9593a717cbd7
--- /dev/null
+++ b/tagscanner.sh
@@ -0,0 +1,6 @@
+#!/usr/bin/bash
+
+export WINEARCH="${REPLACE_WINEARCH}"
+export WINEPREFIX="${REPLACE_WINEPREFIX}"
+
+wine /opt/tagscanner/Tagscan.exe