summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJP-Ellis2020-05-20 21:36:39 +1000
committerJP-Ellis2020-05-20 21:36:39 +1000
commiteed6de4934e81e8d15ac6beef306d69dd0748e86 (patch)
tree03a2f6a653b3f8f4bd4a47afb8c7db910fa3833e
parentf4f5a2ca93d64df37dcd835a531a9fff72e4b552 (diff)
downloadaur-eed6de4934e81e8d15ac6beef306d69dd0748e86.tar.gz
Update to papis 0.10
-rw-r--r--.SRCINFO35
-rw-r--r--73e740b17d47e3ccddc72b58221f21a431b49d46.patch39
-rw-r--r--PKGBUILD36
-rw-r--r--b8ce11c08dc32051545e73e858f0cd044ac12ef2.patch73
-rw-r--r--bfe0ffae835dc5769198ae4aa5625ce44076eeb7.patch32
5 files changed, 105 insertions, 110 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9fcbcf7cc0db..97641974da05 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,38 +1,35 @@
pkgbase = papis
pkgdesc = Papis is a powerful and highly extensible command-line based document and bibliography manager.
- pkgver = 0.9
- pkgrel = 2
+ pkgver = 0.10
+ pkgrel = 1
url = https://github.com/papis/papis
arch = any
license = GPL
depends = python
+ depends = python-requests
+ depends = python-filetype
+ depends = python-pyparsing
depends = python-arxiv2bib
+ depends = python-pyaml
+ depends = python-chardet
depends = python-beautifulsoup4
+ depends = python-colorama
depends = python-bibtexparser
- depends = python-chardet
depends = python-click
- depends = python-colorama
- depends = python-doi
- depends = python-filetype
depends = python-habanero
depends = python-isbnlib
- depends = python-lxml
depends = python-prompt_toolkit
- depends = python-pyaml
+ depends = python-tqdm
depends = python-pygments
- depends = python-pylibgen
- depends = python-pyparsing
- depends = python-requests
- depends = python-slugify
depends = python-stevedore
- depends = python-tqdm
+ depends = python-doi
+ depends = python-typing_extensions
+ depends = python-lxml
optdepends = papis-rofi: integration with rofi
- source = https://files.pythonhosted.org/packages/source/p/papis/papis-0.9.tar.gz
- source = bfe0ffae835dc5769198ae4aa5625ce44076eeb7.patch
- source = 73e740b17d47e3ccddc72b58221f21a431b49d46.patch
- sha256sums = 6a1070ea9a8345dde9cb5d9ccda582e2592520f987d0cfefa6f95d714bf5fd42
- sha256sums = 90534a40b12bcf3cc206ee11737fdb0bdf21cc6b56405ee9a8363a5a83b8e5fc
- sha256sums = 0f49015e96084fa6e978d69d695133a9753bd914fa0eb5bb1a7ee7348182fc7d
+ source = https://files.pythonhosted.org/packages/source/p/papis/papis-0.10.tar.gz
+ source = b8ce11c08dc32051545e73e858f0cd044ac12ef2.patch
+ sha256sums = 0668bba24c0ea159fd9f3497f8f26b1e27e8bc9d9f9a52c82ef28835ee4ec4d1
+ sha256sums = 261f466e0a1765621877eef3b2b6498a2e54576d52b6fac66e52b7322d0d5608
pkgname = papis
diff --git a/73e740b17d47e3ccddc72b58221f21a431b49d46.patch b/73e740b17d47e3ccddc72b58221f21a431b49d46.patch
deleted file mode 100644
index a2b23a55d05c..000000000000
--- a/73e740b17d47e3ccddc72b58221f21a431b49d46.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-From 73e740b17d47e3ccddc72b58221f21a431b49d46 Mon Sep 17 00:00:00 2001
-From: JP-Ellis <josh@jpellis.me>
-Date: Mon, 2 Dec 2019 11:33:52 +1100
-Subject: [PATCH] Remove upper limits on dependencies
-
-Upper limits can be re-instated if/when an incompatibility is discovered (and
-until papis can be updated to be compatible with the newer version).
-
-Signed-off-by: JP-Ellis <josh@jpellis.me>
----
- setup.py | 10 ++++++----
- 1 file changed, 6 insertions(+), 4 deletions(-)
-
-diff --git a/setup.py b/setup.py
-index 38cfbe0c..7e7c3bf9 100644
---- a/setup.py
-+++ b/setup.py
-@@ -65,15 +65,17 @@
- "bibtexparser>=0.6.2",
- "click>=7.0.0",
- "habanero>=0.6.0",
-- "isbnlib>=3.9.1,<4.0.0",
-- "prompt_toolkit>=2.0.5,<3",
-+ "isbnlib>=3.9.1",
-+ "prompt_toolkit>=2.0.5",
- "tqdm>=4.1",
- "pygments>=2.2.0",
- "stevedore>=1.30",
- "python-doi>=0.1.1",
- # for python 3.4
-- "lxml<=4.3.5",
-- "python-slugify>=1.2.6,<4",
-+ "lxml<=4.3.5 ; python_version<='3.5'",
-+ "lxml>=4.3.5 ; python_version>'3.5'",
-+ "python-slugify>=1.2.6,<4 ; python_version<='3.4'",
-+ "python-slugify>=1.2.6 ; python_version>'3.4'",
- ],
- python_requires='>=3',
- classifiers=[
diff --git a/PKGBUILD b/PKGBUILD
index 7329a6c6e870..1edd9e72644b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,46 +1,42 @@
# Maintainer: JP-Ellis <josh@jpellis.me>
pkgname=papis
-pkgver=0.9
-pkgrel=2
+pkgver=0.10
+pkgrel=1
pkgdesc="Papis is a powerful and highly extensible command-line based document and bibliography manager."
arch=('any')
url="https://github.com/papis/papis"
license=('GPL')
depends=('python'
+ 'python-requests'
+ 'python-filetype'
+ 'python-pyparsing'
'python-arxiv2bib'
+ 'python-pyaml'
+ 'python-chardet'
'python-beautifulsoup4'
+ 'python-colorama'
'python-bibtexparser'
- 'python-chardet'
'python-click'
- 'python-colorama'
- 'python-doi'
- 'python-filetype'
'python-habanero'
'python-isbnlib'
- 'python-lxml'
'python-prompt_toolkit'
- 'python-pyaml'
+ 'python-tqdm'
'python-pygments'
- 'python-pylibgen'
- 'python-pyparsing'
- 'python-requests'
- 'python-slugify'
'python-stevedore'
- 'python-tqdm'
+ 'python-doi'
+ 'python-typing_extensions'
+ 'python-lxml'
)
optdepends=('papis-rofi: integration with rofi')
source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/${pkgname}/${pkgname}-${pkgver}.tar.gz"
- "bfe0ffae835dc5769198ae4aa5625ce44076eeb7.patch"
- "73e740b17d47e3ccddc72b58221f21a431b49d46.patch")
-sha256sums=('6a1070ea9a8345dde9cb5d9ccda582e2592520f987d0cfefa6f95d714bf5fd42'
- '90534a40b12bcf3cc206ee11737fdb0bdf21cc6b56405ee9a8363a5a83b8e5fc'
- '0f49015e96084fa6e978d69d695133a9753bd914fa0eb5bb1a7ee7348182fc7d')
+ "b8ce11c08dc32051545e73e858f0cd044ac12ef2.patch")
+sha256sums=('0668bba24c0ea159fd9f3497f8f26b1e27e8bc9d9f9a52c82ef28835ee4ec4d1'
+ '261f466e0a1765621877eef3b2b6498a2e54576d52b6fac66e52b7322d0d5608')
noextract=()
prepare() {
cd "${srcdir}/${pkgname}-${pkgver}"
- patch -p 1 -i "${srcdir}/bfe0ffae835dc5769198ae4aa5625ce44076eeb7.patch"
- patch -p 1 -i "${srcdir}/73e740b17d47e3ccddc72b58221f21a431b49d46.patch"
+ patch -p 1 < "${srcdir}/b8ce11c08dc32051545e73e858f0cd044ac12ef2.patch"
}
build() {
diff --git a/b8ce11c08dc32051545e73e858f0cd044ac12ef2.patch b/b8ce11c08dc32051545e73e858f0cd044ac12ef2.patch
new file mode 100644
index 000000000000..cedf1ed35734
--- /dev/null
+++ b/b8ce11c08dc32051545e73e858f0cd044ac12ef2.patch
@@ -0,0 +1,73 @@
+From b8ce11c08dc32051545e73e858f0cd044ac12ef2 Mon Sep 17 00:00:00 2001
+From: Alexandru Fikl <alexfikl@gmail.com>
+Date: Sun, 3 May 2020 10:51:49 -0500
+Subject: [PATCH] add compatibility with isbnlib >= 3.10
+
+---
+ papis/isbn.py | 21 ++++++++++++---------
+ setup.py | 2 +-
+ 2 files changed, 13 insertions(+), 10 deletions(-)
+
+diff --git a/papis/isbn.py b/papis/isbn.py
+index fe137cd3..0bbfbd52 100644
+--- a/papis/isbn.py
++++ b/papis/isbn.py
+@@ -1,6 +1,7 @@
+ import papis.document
+ import logging
+ import isbnlib
++import isbnlib.registry
+ import click
+ # See https://github.com/xlcnd/isbnlib for details
+ from typing import Optional, Dict, Any, List
+@@ -11,18 +12,20 @@
+ def get_data(
+ query: str = "",
+ service: Optional[str] = None) -> List[Dict[str, Any]]:
+- global logger
+- results = [] # type: List[Dict[str, Any]]
++ isbnlib_version = tuple(int(n) for n in isbnlib.__version__.split('.'))
++ if service is None and isbnlib_version >= (3, 10, 0):
++ service = "default"
++
+ logger.debug('Trying to retrieve isbn')
+ isbn = isbnlib.isbn_from_words(query)
+ data = isbnlib.meta(isbn, service=service)
+- if data is None:
+- return results
+- else:
+- logger.debug('Trying to retrieve isbn')
+- assert(isinstance(data, dict))
++
++ results = [] # type: List[Dict[str, Any]]
++ if data is not None:
++ assert isinstance(data, dict)
+ results.append(data_to_papis(data))
+- return results
++
++ return results
+
+
+ def data_to_papis(data: Dict[str, Any]) -> Dict[str, Any]:
+@@ -45,7 +48,7 @@ def data_to_papis(data: Dict[str, Any]) -> Dict[str, Any]:
+ '--service',
+ '-s',
+ default='goob',
+- type=click.Choice(['wcat', 'goob', 'openl'])
++ type=click.Choice(list(isbnlib.registry.services.keys()))
+ )
+ def explorer(ctx: click.core.Context, query: str, service: str) -> None:
+ """
+diff --git a/setup.py b/setup.py
+index 65fc183c..dd136e71 100644
+--- a/setup.py
++++ b/setup.py
+@@ -65,7 +65,7 @@
+ "bibtexparser>=0.6.2",
+ "click>=7.0.0",
+ "habanero>=0.6.0",
+- "isbnlib>=3.9.1,<3.10",
++ "isbnlib>=3.9.1",
+ "prompt_toolkit>=2.0.5",
+ "tqdm>=4.1",
+ "pygments>=2.2.0",
diff --git a/bfe0ffae835dc5769198ae4aa5625ce44076eeb7.patch b/bfe0ffae835dc5769198ae4aa5625ce44076eeb7.patch
deleted file mode 100644
index a8be1305a48d..000000000000
--- a/bfe0ffae835dc5769198ae4aa5625ce44076eeb7.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-From bfe0ffae835dc5769198ae4aa5625ce44076eeb7 Mon Sep 17 00:00:00 2001
-From: JP-Ellis <josh@jpellis.me>
-Date: Mon, 2 Dec 2019 21:19:46 +1100
-Subject: [PATCH] Update supported Python version to 3.5, 3.6, 3.7 & 3.8
-
-It's probably safe to drop support for Python <= 3.4 as they are neither
-maintained nor receiving security fixes.
-
-Signed-off-by: JP-Ellis <josh@jpellis.me>
----
- .travis.yml | 3 +--
- appveyor.yml | 10 ++++------
- setup.py | 4 ++--
- 3 files changed, 7 insertions(+), 10 deletions(-)
-
-diff --git a/.travis.yml b/.travis.yml
-index a94caae6..6f73695a 100644
---- a/setup.py
-+++ b/setup.py
-@@ -86,10 +86,10 @@
- 'Operating System :: MacOS',
- 'Operating System :: POSIX',
- 'Operating System :: Unix',
-- 'Programming Language :: Python :: 3.3',
-- 'Programming Language :: Python :: 3.4',
- 'Programming Language :: Python :: 3.5',
- 'Programming Language :: Python :: 3.6',
-+ 'Programming Language :: Python :: 3.7',
-+ 'Programming Language :: Python :: 3.8',
- 'Topic :: Utilities',
- ],
- extras_require=dict(