summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbtd13372018-09-01 21:12:39 -0300
committerbtd13372018-09-01 21:12:39 -0300
commitef428786c39ab3c20170a06fcbf63bce6545d851 (patch)
treed6ba22177d39e880243d093f5cea2f49938b01da
parent9659edf76c10ead730bf11ecb4d628ddf5518eb5 (diff)
downloadaur-ef428786c39ab3c20170a06fcbf63bce6545d851.tar.gz
Fix variables and version
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD13
2 files changed, 8 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2d66107cb5f3..bc03a373649c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = newaita-icons-git
pkgdesc = Newaita icon theme is a Linux icon theme combining old style and color of material design. If you urgently needed any icon, please write in the comments on the page https://store.kde.org/p/1243493/ If you want support me Paypal: ghostdmn2@gmail.com
- pkgver = r218.2a95a1cf
+ pkgver = latest
pkgrel = 1
url = https://github.com/cbrnix/Newaita
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index 4ed85d715f16..fcc21ce16151 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,14 @@
# Maintainer: Helder Bertoldo <helder.bertoldo@gmail.com>
+# Contributor:
-gitname=Newaita
-author=cbrnix
+_gitname=Newaita
+_author=cbrnix
pkgname=newaita-icons-git
-pkgver=r218.2a95a1cf
+pkgver=latest
pkgrel=1
pkgdesc="Newaita icon theme is a Linux icon theme combining old style and color of material design. If you urgently needed any icon, please write in the comments on the page https://store.kde.org/p/1243493/ If you want support me Paypal: ghostdmn2@gmail.com"
arch=('i686' 'x86_64')
-url="https://github.com/${author}/${gitname}"
+url="https://github.com/${_author}/${_gitname}"
license=('CC BY-NC-SA 3.0')
makedepends=('git')
options=('!strip')
@@ -17,7 +18,7 @@ source=("git+${url}.git")
sha256sums=('SKIP')
pkgver(){
- cd "${gitname}"
+ cd "${_gitname}"
( set -o pipefail
git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
@@ -26,7 +27,7 @@ pkgver(){
package() {
install -d ${pkgdir}/usr/share/icons
- cp -r ${gitname}/* ${pkgdir}/usr/share/icons/
+ cp -r ${_gitname}/* ${pkgdir}/usr/share/icons/
find ${pkgdir}/usr -type f -exec chmod 644 {} \;
find ${pkgdir}/usr -type d -exec chmod 755 {} \;
rm -rf "$pkgdir/usr/share/icons/README.md"