summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoryhfudev2015-06-09 12:36:57 -0400
committeryhfudev2015-06-09 12:36:57 -0400
commitef4656857e906db74ce3491e79d7671fc2862dc1 (patch)
tree0fb7f35695abcf6a9dc75fd5ba32faa533ff2821
downloadaur-ef4656857e906db74ce3491e79d7671fc2862dc1.tar.gz
Initial import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD49
2 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d8d6e30842ad
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = libucd-git
+ pkgdesc = Universal Charset Detector C/C++ API
+ pkgver = 553d21c
+ pkgrel = 1
+ url = https://github.com/yhfudev/cpp-libucd.git
+ arch = i686
+ arch = x86_64
+ arch = arm
+ license = GPL
+ makedepends = git
+ depends = gcc-libs
+ depends = bash
+ provides = libucd-git
+ conflicts = libucd
+ source = libucd-git::git+https://github.com/yhfudev/cpp-libucd.git
+ md5sums = SKIP
+
+pkgname = libucd-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..05efc57f0118
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: Yunhui Fu <yhfudev at gmail dot com>
+
+pkgname=libucd-git
+pkgver=553d21c
+pkgrel=1
+pkgdesc="Universal Charset Detector C/C++ API"
+arch=('i686' 'x86_64' 'arm')
+url="https://github.com/yhfudev/cpp-libucd.git"
+license=('GPL')
+depends=('gcc-libs' 'bash')
+makedepends=('git')
+provides=('libucd-git')
+conflicts=('libucd')
+#install="$pkgname.install"
+#PKGEXT=.pkg.tar.xz
+source=(
+ "$pkgname::git+https://github.com/yhfudev/cpp-libucd.git"
+ )
+
+md5sums=(
+ 'SKIP'
+ )
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ local ver="$(git show | grep commit | awk '{print $2}' )"
+ #printf "r%s" "${ver//[[:alpha:]]}"
+ echo ${ver:0:7}
+}
+
+prepare() {
+ cd "$srcdir/$pkgname"
+ #cd "${srcdir}/${pkgname}-${pkgver}"
+ #patch -p0 < "$srcdir/libucd-fix.patch"
+}
+
+build() {
+ cd "$srcdir/$pkgname"
+ #cd "${srcdir}/${pkgname}-${pkgver}"
+ ./autogen.sh
+ ./configure --prefix=/usr --sysconfdir=/etc --mandir=/usr/share/man --disable-static --disable-icu
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ #cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="$pkgdir/" install
+}