summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBioArchLinuxBot2022-07-13 18:01:17 +0000
committerBioArchLinuxBot2022-07-13 18:01:17 +0000
commitef481bdaad4981ddf70fbfcd0a8d8fbe75aefbc9 (patch)
treed5f02313f9597eef006e3168330d2ff60374a95b
parentd2ff6bea71cf23038367c3aa0393b79dc21ed2a5 (diff)
downloadaur-ef481bdaad4981ddf70fbfcd0a8d8fbe75aefbc9.tar.gz
[lilac] updated to 0.10.2-1
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD41
2 files changed, 31 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e9e8dc89128b..9a0fd545c411 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -3,14 +3,16 @@ pkgbase = r-corpus
pkgver = 0.10.2
pkgrel = 1
url = https://cran.r-project.org/package=corpus
- arch = i686
arch = x86_64
- license = Apache2.0
- depends = r>=3.3
- depends = r-utf8>=1.1.0
+ license = Apache
+ depends = r
+ depends = r-utf8
optdepends = r-knitr
+ optdepends = r-matrix
+ optdepends = r-quanteda
optdepends = r-rmarkdown
optdepends = r-testthat
+ optdepends = r-tm
source = https://cran.r-project.org/src/contrib/corpus_0.10.2.tar.gz
sha256sums = c4647fae59d7acf9d4397a5126d386c8d323ad469df9800184de95b63a1aaa3b
diff --git a/PKGBUILD b/PKGBUILD
index 536bbc3f3ad6..d1e865eb8d22 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,35 @@
-# Contributor: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
-# Contributor: Clint Valentine <valentine.clint@gmail.com>
+# Maintainer: sukanka <su975853527@gmail.com>
-_cranname=corpus
-_cranver=0.10.2
-pkgname=r-${_cranname,,}
-pkgver=${_cranver//[:-]/.}
+_pkgname=corpus
+_pkgver=0.10.2
+pkgname=r-${_pkgname,,}
+pkgver=0.10.2
pkgrel=1
-pkgdesc="Text Corpus Analysis"
-arch=(i686 x86_64)
-url="https://cran.r-project.org/package=${_cranname}"
-license=(Apache2.0)
-depends=('r>=3.3' 'r-utf8>=1.1.0')
-optdepends=(r-knitr r-rmarkdown r-testthat)
-source=("https://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
+pkgdesc='Text Corpus Analysis'
+arch=('x86_64')
+url="https://cran.r-project.org/package=${_pkgname}"
+license=('Apache')
+depends=(
+ r
+ r-utf8
+)
+optdepends=(
+ r-knitr
+ r-matrix
+ r-quanteda
+ r-rmarkdown
+ r-testthat
+ r-tm
+)
+source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
sha256sums=('c4647fae59d7acf9d4397a5126d386c8d323ad469df9800184de95b63a1aaa3b')
build() {
- R CMD INSTALL ${_cranname}_${_cranver}.tar.gz -l "${srcdir}"
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
}
package() {
install -dm0755 "${pkgdir}/usr/lib/R/library"
-
- cp -a --no-preserve=ownership "${_cranname}" "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
}
+# vim:set ts=2 sw=2 et: