summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThibault Boyeux2020-12-08 16:38:30 +0000
committerThibault Boyeux2020-12-08 16:38:30 +0000
commitef50e493fcce5a576278990f482a428f130b9110 (patch)
tree4ee74b093abdb11d8e39f06c00679038af57f457
downloadaur-ef50e493fcce5a576278990f482a428f130b9110.tar.gz
Update PKGBUILD and .SRCINFO with GitHub Actions
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD76
2 files changed, 96 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f47f523fcf96
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = sqlite-fts3-parenthesis
+ pkgdesc = A C library that implements an SQL database engine. Compiled with 'SQLITE_ENABLE_FTS3_PARENTHESIS' option to allow operators AND and NOT and nested parenthesis in queries.
+ pkgver = 3.34.0
+ pkgrel = 1
+ url = https://www.sqlite.org/
+ arch = x86_64
+ license = custom:Public Domain
+ makedepends = tcl
+ depends = readline
+ depends = zlib
+ provides = sqlite=3.34.0
+ conflicts = sqlite
+ replaces = sqlite3
+ options = !emptydirs
+ options = !makeflags
+ source = https://www.sqlite.org/2020/sqlite-src-3340000.zip
+ sha256sums = a5c2000ece56d2de13c474658b9cdba6b7f2608a4d711e245518ea02a2a2333e
+
+pkgname = sqlite-fts3-parenthesis
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6c1a47ded688
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,76 @@
+# Maintainer: Andreas Radke <andyrtr@archlinux.org>
+# Contributor: Tom Newsom <Jeepster@gmx.co.uk>
+
+pkgname=('sqlite-fts3-parenthesis')
+_srcver=3340000
+_docver=${_srcver}
+pkgver=3.34.0
+pkgrel=1
+pkgdesc="A C library that implements an SQL database engine. Compiled with 'SQLITE_ENABLE_FTS3_PARENTHESIS' option to allow operators AND and NOT and nested parenthesis in queries."
+arch=('x86_64')
+license=('custom:Public Domain')
+url="https://www.sqlite.org/"
+makedepends=('tcl')
+depends=('readline' 'zlib')
+conflicts=("sqlite")
+provides=("sqlite=$pkgver")
+replaces=("sqlite3")
+source=(https://www.sqlite.org/2020/sqlite-src-${_srcver}.zip)
+options=('!emptydirs' '!makeflags') # json extensions breaks parallel build
+# upstream now switched to sha3sums - currently not suppoerted by makepkg
+sha256sums=('a5c2000ece56d2de13c474658b9cdba6b7f2608a4d711e245518ea02a2a2333e')
+
+package() {
+ cd sqlite-src-$_srcver
+ make DESTDIR="${pkgdir}" install
+
+ install -m755 showdb showjournal showstat4 showwal sqldiff "${pkgdir}"/usr/bin/
+
+ # install manpage
+ install -m755 -d "${pkgdir}"/usr/share/man/man1
+ install -m644 sqlite3.1 "${pkgdir}"/usr/share/man/man1/
+
+ # license - no linking required because pkgbase=pkgname
+ install -D -m644 LICENSE.md "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ # split out tcl extension
+ mkdir "$srcdir"/tcl
+ mv "$pkgdir"/usr/lib/sqlite* "$srcdir"/tcl
+}
+
+prepare() {
+ cd sqlite-src-$_srcver
+
+ # patch taken from Fedora
+ # https://src.fedoraproject.org/rpms/sqlite/blob/master/f/sqlite.spec
+# patch -Np1 -i ../sqlite-lemon-system-template.patch
+
+# autoreconf -vfi
+}
+
+build() {
+ export CPPFLAGS="$CPPFLAGS -DSQLITE_ENABLE_COLUMN_METADATA=1 \
+ -DSQLITE_ENABLE_UNLOCK_NOTIFY \
+ -DSQLITE_ENABLE_DBSTAT_VTAB=1 \
+ -DSQLITE_ENABLE_FTS3_TOKENIZER=1 \
+ -DSQLITE_ENABLE_FTS3_PARENTHESIS \
+ -DSQLITE_SECURE_DELETE \
+ -DSQLITE_MAX_VARIABLE_NUMBER=250000 \
+ -DSQLITE_MAX_EXPR_DEPTH=10000"
+
+ # build sqlite
+ cd sqlite-src-$_srcver
+ ./configure --prefix=/usr \
+ --disable-static \
+ --disable-amalgamation \
+ --enable-fts3 \
+ --enable-fts4 \
+ --enable-fts5 \
+ --enable-rtree \
+ --enable-json1 \
+ TCLLIBDIR=/usr/lib/sqlite$pkgver
+ sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
+ make
+ # build additional tools
+ make showdb showjournal showstat4 showwal sqldiff sqlite3_analyzer
+}
+