summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHoward Cheung2020-08-05 20:21:53 +0800
committerHoward Cheung2020-08-05 20:21:53 +0800
commitef50ee3f22844d466baebced4a1d2ccfe45c9749 (patch)
tree1f418d9d1e3f0f7be07b7abd050b44879d8baf4f
parent42c18bd7e098c019970cbedaddcc9d2305194bbb (diff)
downloadaur-ef50ee3f22844d466baebced4a1d2ccfe45c9749.tar.gz
reflector, switch to cgroup v2
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD12
2 files changed, 10 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 51e339adc771..55f926b9a606 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = clash-tun
pkgdesc = Clash Tun Scripts for Linux
- pkgver = 20200620.r459.796233a
- pkgrel = 1
+ pkgver = 20200805.r503.7f77c72
+ pkgrel = 2
url = https://github.com/h0cheung/kr328-clash-setup-scripts
arch = any
license = custom
@@ -14,7 +14,7 @@ pkgbase = clash-tun
conflicts = clash-dev-git
backup = etc/clash-tun/env
source = git+https://github.com/comzyh/clash#branch=add-water
- source = git+https://github.com/h0cheung/kr328-clash-setup-scripts
+ source = git+https://github.com/h0cheung/clash-tun-scripts
source = https://raw.githubusercontent.com/comzyh/clash/master/LICENSE
md5sums = SKIP
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 890c37c5fe28..45664d43d841 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: h_cheung <mail@h-cheung.cf>
pkgname=clash-tun
-pkgver=20200620.r459.796233a
-pkgrel=1
+pkgver=20200805.r503.7f77c72
+pkgrel=2
pkgdesc="Clash Tun Scripts for Linux"
arch=('any')
url="https://github.com/h0cheung/kr328-clash-setup-scripts"
@@ -14,7 +14,7 @@ depends=('glibc')
backup=(etc/clash-tun/env)
options=()
source=("git+https://github.com/comzyh/clash#branch=add-water"
- "git+https://github.com/h0cheung/kr328-clash-setup-scripts"
+ "git+https://github.com/h0cheung/clash-tun-scripts"
"https://raw.githubusercontent.com/comzyh/clash/master/LICENSE")
md5sums=('SKIP'
'SKIP'
@@ -32,15 +32,17 @@ pkgver() {
build() {
cd "${srcdir}/clash"
go build .
+ cd "${srcdir}/clash-tun-scripts"
+ g++ $CPPFLAGS $CXXFLAGS -std=c++17 -static -o bypass-proxy-pid bypass-proxy-pid.cc
}
package() {
cd "${srcdir}/clash"
install -m 755 -D "clash" "${pkgdir}/usr/bin/clash"
install -m 644 -D "${srcdir}/LICENSE" "${pkgdir}/usr/share/licenses/clash/LICENSE"
- cd "${srcdir}/kr328-clash-setup-scripts"
+ cd "${srcdir}/clash-tun-scripts"
install -m 755 -D "bypass-proxy" "${pkgdir}/usr/bin/bypass-proxy"
- install -m 755 -D "bypass-proxy-pid" "${pkgdir}/usr/bin/bypass-proxy-pid"
+ install -m 4755 -D "bypass-proxy-pid" "${pkgdir}/usr/bin/bypass-proxy-pid"
install -m 744 -D "setup-clash-tun.sh" "${pkgdir}/opt/script/setup-clash-tun.sh"
install -m 744 -D "setup-clash-cgroup.sh" "${pkgdir}/opt/script/setup-clash-cgroup.sh"
install -m 744 -D "clean-clash-tun.sh" "${pkgdir}/opt/script/clean-clash-tun.sh"