summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhoton892015-06-29 09:12:40 +0200
committerPhoton892015-06-29 09:12:40 +0200
commitef5c075357864558521c32256d53ae074c9d6432 (patch)
treeb4ad89ce62da0b4a731b18fed00b34c9aba29451
downloadaur-ef5c075357864558521c32256d53ae074c9d6432.tar.gz
Initial import
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD23
-rw-r--r--python27.patch11
3 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9f157309bdcb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = jngl
+ pkgdesc = One of the easiest 2D game libraries for C++ and Python
+ pkgver = 0.9.2
+ pkgrel = 3
+ url = http://jngl.watteimdocht.de/
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = scons
+ makedepends = git
+ depends = boost
+ depends = freetype2
+ depends = fontconfig
+ depends = glib2
+ depends = libjpeg6
+ depends = libpng12
+ depends = libvorbis
+ depends = libxext
+ depends = libxxf86vm
+ depends = mesa
+ depends = openal
+ depends = python2
+ source = python27.patch
+ md5sums = 58ec66f99186c5e491a4657559f203d1
+ sha1sums = 61c55403238c7c7d95de87bb720230f47fd75a62
+
+pkgname = jngl
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f4ab000fd429
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Michael Kogan <michael dot kogan at gmx dot net>
+
+pkgname=jngl
+pkgver=0.9.2
+pkgrel=3
+pkgdesc="One of the easiest 2D game libraries for C++ and Python"
+arch=('i686' 'x86_64')
+url="http://jngl.watteimdocht.de/"
+license=('GPL3')
+depends=('boost' 'freetype2' 'fontconfig' 'glib2' 'libjpeg6' 'libpng12' 'libvorbis' 'libxext' 'libxxf86vm' 'mesa' 'openal' 'python2')
+makedepends=('scons' 'git')
+source=('python27.patch')
+md5sums=('58ec66f99186c5e491a4657559f203d1')
+sha1sums=('61c55403238c7c7d95de87bb720230f47fd75a62')
+
+build() {
+ git clone https://github.com/jhasse/JNGL.git
+ patch $srcdir/JNGL/SConstruct < python27.patch
+ cd $srcdir/JNGL
+ scons python=1|| return 1
+ ./install.sh $pkgdir/usr || return 1
+ install -D -m644 "$srcdir/JNGL/python/libjngl.so" "${pkgdir}/usr/lib/python2.7/site-packages/jngl.so" || return 1
+}
diff --git a/python27.patch b/python27.patch
new file mode 100644
index 000000000000..347058f545d4
--- /dev/null
+++ b/python27.patch
@@ -0,0 +1,11 @@
+--- SConstruct_old 2011-05-16 20:49:44.192374630 +0200
++++ SConstruct 2011-05-16 20:48:34.254626319 +0200
+@@ -110,7 +110,7 @@
+ env.ParseConfig("pkg-config --cflags --libs jngl.pc")
+ env.Append(CPPPATH="/usr/include/python2.7",
+ LIBPATH=Split(". ./lib ./python"),
+- LIBS=Split("python2.7 boost_python-py27"))
++ LIBS=Split("python2.7 boost_python"))
+ env.SharedLibrary(target="python/jngl.so",
+ source="python/main.cpp")
+