summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKazuki Shigemichi2018-03-25 11:44:02 +0000
committerKazuki Shigemichi2018-03-25 11:45:17 +0000
commitef86bc745e2f4a96cb535bf444c227c61395f779 (patch)
treebb9aae4733fea6fa2d736a6d294114da1099a05d
downloadaur-ef86bc745e2f4a96cb535bf444c227c61395f779.tar.gz
initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD34
3 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..854a43af50f5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = roswell-git
+ pkgdesc = Lisp installer and launcher
+ pkgver = 18.3.10.89.r25.ge39397a
+ pkgrel = 1
+ url = https://github.com/roswell/roswell
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ depends = curl
+ provides = roswell
+ conflicts = roswell
+ source = git+https://github.com/roswell/roswell.git
+ md5sums = SKIP
+
+pkgname = roswell-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..254fe767ca33
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/src
+/pkg
+/roswell
+*.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d58d5045a503
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Kazuki Shigemichi <shigemichik@gmail.com>
+# Forked from https://aur.archlinux.org/packages/roswell/
+# Maintainer: Thayne McCombs <bytecurry.software@gmail.com>
+pkgname="roswell-git"
+pkgver="18.3.10.89.r25.ge39397a"
+pkgrel=1
+pkgdesc="Lisp installer and launcher"
+url="https://github.com/roswell/roswell"
+arch=('i686' 'x86_64')
+license=('MIT')
+depends=('curl')
+makedepends=('git')
+conflicts=('roswell')
+provides=('roswell')
+source=("git+https://github.com/roswell/roswell.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname%-git}"
+ git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/g;s/-/./g'
+}
+
+build() {
+ cd "${pkgname%-git}"
+ ./bootstrap
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "${pkgname%-git}"
+ make DESTDIR="$pkgdir/" install
+ install -D COPYING "$pkgdir/usr/share/licenses/roswell/LICENSE"
+}