summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSergey Shatunov2020-06-09 03:53:28 +0700
committerSergey Shatunov2020-06-09 03:53:28 +0700
commitef8d7be4071a37d924449f113b924f5a81b18c13 (patch)
tree3b5f66993492e79a36c76a3368ebca4296a65e4e
parent6094166aaece70bd5bfe5b7144ab25e48d27da15 (diff)
downloadaur-ef8d7be4071a37d924449f113b924f5a81b18c13.tar.gz
Update half-memory example to the latest changed in master
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--half-memory.conf.example18
3 files changed, 20 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index abcad63253ea..8be698cf284c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = zram-generator-git
pkgdesc = Systemd unit generator for zram devices
- pkgver = 0.1.2+15+gf78b8ac
+ pkgver = 0.1.2+23+g9de243e
pkgrel = 1
url = https://github.com/systemd/zram-generator
install = zram-generator.install
@@ -15,7 +15,7 @@ pkgbase = zram-generator-git
source = half-memory.conf.example
source = zram-generator.install
sha256sums = SKIP
- sha256sums = 1d8939e449d7a09c4f6e1783039f6324fc3fe1969e0573ff4ed9d27b8b9d43f9
+ sha256sums = 1aa3e7a47303c0b2dff6d74cc569c12e8009ed4642301db67fb389cb313141cf
sha256sums = 17f510e96f763d1c9aa8c0de757ad38dbe089465fb802e3c34682793f060bf77
pkgname = zram-generator-git
diff --git a/PKGBUILD b/PKGBUILD
index f110d12b3364..7b312eae7926 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Sergey Shatunov <me@prok.pw>
pkgname=zram-generator-git
-pkgver=0.1.2+15+gf78b8ac
+pkgver=0.1.2+23+g9de243e
pkgrel=1
pkgdesc="Systemd unit generator for zram devices"
arch=("x86_64")
@@ -15,7 +15,7 @@ source=("${pkgname%-git}::git+https://github.com/systemd/zram-generator.git#bran
'half-memory.conf.example'
'zram-generator.install')
sha256sums=('SKIP'
- '1d8939e449d7a09c4f6e1783039f6324fc3fe1969e0573ff4ed9d27b8b9d43f9'
+ '1aa3e7a47303c0b2dff6d74cc569c12e8009ed4642301db67fb389cb313141cf'
'17f510e96f763d1c9aa8c0de757ad38dbe089465fb802e3c34682793f060bf77')
pkgver() {
diff --git a/half-memory.conf.example b/half-memory.conf.example
index 2ee122eb7547..f5d589616acb 100644
--- a/half-memory.conf.example
+++ b/half-memory.conf.example
@@ -7,8 +7,8 @@
# The default is 2048 MiB, i.e. the device is only created on machines
# with limited memory.
#
-# "memory-limit = none" may be used to disable this limit.
-memory-limit = none
+# "host-memory-limit = none" may be used to disable this limit.
+host-memory-limit = none
# The fraction of memory to use as ZRAM. For example, if the machine
# has 1 GiB, and zram-fraction=0.25, then the zram device will have
@@ -17,3 +17,17 @@ memory-limit = none
# The default is 0.25.
zram-fraction = 0.5
+# The maximum size of the zram device (in MiB).
+#
+# If host-memory times zram-fraction is greater than this,
+# the size will be capped to this amount;
+# for example, on a machine with 2 GiB of RAM and with zram-fraction=0.5,
+# the device would still be 512 MiB in size due to the limit below.
+#
+# The default is 4096.
+max-zram-size = none
+
+# The compression algorithm to use for the zram device,
+# or leave unspecified for your distribution's default.
+compression-algorithm = lzo-rle
+