summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhayao2020-03-07 12:48:51 +0900
committerhayao2020-03-07 12:48:51 +0900
commitefbc125e8bae33b124e6d63c2a689eecf76c21b9 (patch)
tree107a737194ed6393ed6233bbc030867f174c4e0c
parentd805b16465b38fd80e46ad5a73eff0634b7edaed (diff)
downloadaur-efbc125e8bae33b124e6d63c2a689eecf76c21b9.tar.gz
Fixed symbolic links.
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD9
2 files changed, 7 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a19e5c2ce038..31ad6e56ee0a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = aptpac-git
pkgdesc = a pacman wrapper with syntax from debian's apt
pkgver = 2.0.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/Hayao0819/aptpac
arch = i686
arch = x86_64
@@ -10,6 +10,7 @@ pkgbase = aptpac-git
depends = sudo
conflicts = apt
conflicts = apt-git
+ conflicts = aptpac
source = git://github.com/Hayao0819/aptpac.git
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index fb797cc03c57..35366e4c8e0f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=aptpac-git
pkgver=2.0.0
-pkgrel=1
+pkgrel=2
pkgdesc="a pacman wrapper with syntax from debian's apt"
arch=('i686' 'x86_64')
url="https://github.com/Hayao0819/aptpac"
@@ -13,7 +13,7 @@ makedepends=('git')
source=('git://github.com/Hayao0819/aptpac.git')
md5sums=('SKIP')
_gitname='aptpac'
-conflicts=('apt' 'apt-git')
+conflicts=('apt' 'apt-git' 'aptpac')
pkgver() {
cd "${_gitname}" &&
@@ -24,6 +24,7 @@ pkgver() {
package() {
cd "${_gitname}" &&
install -m 755 -D aptpac "${pkgdir}/usr/bin/aptpac"
- ln -s "${pkgdir}/usr/bin/aptpac" "${pkgdir}/usr/bin/apt"
- ln -s "${pkgdir}/usr/bin/aptpac" "${pkgdir}/usr/bin/apt-get"
+ cd "${pkgdir}/usr/bin/"
+ ln -s "aptpac" "apt"
+ ln -s "aptpac" "apt-get"
}