summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKnut Ahlers2020-07-28 20:49:10 +0200
committerKnut Ahlers2020-07-28 20:49:15 +0200
commitf00edfa368e563eeb1d6207585d5a137fef64a7a (patch)
treef4c67363fd325d7eab8e850e0202394411ad26b0
parent55073b33982771f0ca87a9d546933227a71c34a9 (diff)
downloadaur-f00edfa368e563eeb1d6207585d5a137fef64a7a.tar.gz
Switch version search to Debian repo
Signed-off-by: Knut Ahlers <knut@ahlers.me>
-rwxr-xr-xupdate_version.sh10
1 files changed, 6 insertions, 4 deletions
diff --git a/update_version.sh b/update_version.sh
index 0a11328dada8..2471f7792dd9 100755
--- a/update_version.sh
+++ b/update_version.sh
@@ -6,16 +6,16 @@ CHANNEL=$(awk -F '=' '/^_channel/{ print $2 }' PKGBUILD)
PKG="google-chrome-${CHANNEL}"
# Get latest version
-VER=$(curl -sL "https://dl.google.com/linux/chrome/rpm/stable/x86_64/repodata/other.xml.gz" | gzip -df |
- tr ' ' '\n' | grep -e name= -e ver= | cut -d '"' -f2 | sed 'N;s/\n/ /' |
- grep "${PKG}" | cut -d ' ' -f 2)
+VER=$(curl -sSf https://dl.google.com/linux/chrome/deb/dists/stable/main/binary-amd64/Packages |
+ grep -A1 "Package: ${PKG}" |
+ awk '/Version/{print $2}' |
+ cut -d '-' -f1)
# Insert latest version into PKGBUILD and update hashes
sed -i \
-e "s/^pkgver=.*/pkgver=${VER}/" \
-e 's/pkgrel=.*/pkgrel=1/' \
PKGBUILD
-updpkgsums
# Check whether this changed anything
if (git diff --exit-code PKGBUILD); then
@@ -23,6 +23,8 @@ if (git diff --exit-code PKGBUILD); then
exit 0
fi
+updpkgsums
+
# Update .SRCINFO
makepkg --printsrcinfo >.SRCINFO