summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortrya2015-06-08 23:35:39 +0200
committertrya2015-06-08 23:35:39 +0200
commitf029b32f9178a3d848a05279ee5d749268f82f8f (patch)
treec3bcc82c1c0e18c26c067290b93d388dcdc8cd42
downloadaur-f029b32f9178a3d848a05279ee5d749268f82f8f.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD26
-rw-r--r--mach64drm.install22
3 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f94f205477e7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = mach64drm
+ pkgdesc = Mach64 DRM module
+ pkgver = 20150222
+ pkgrel = 1
+ url = http://dri.freedesktop.org/wiki/DRM
+ install = mach64drm.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = linux-headers
+ depends = linux
+ optdepends = mach64-dri: Mesa DRI drivers for Mach64
+ optdepends = xf86-video-mach64: X.Org Mach64 video driver
+ source = http://trya.alwaysdata.net/linux/mach64-20150222.tar.gz
+ md5sums = b763647c584bb524db3d7418651dcd4e
+
+pkgname = mach64drm
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1f9d39cece89
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: trya <tryagainprod@gmail.com>
+
+pkgname=mach64drm
+pkgver=20150222
+pkgrel=1
+pkgdesc="Mach64 DRM module"
+arch=('i686' 'x86_64')
+url="http://dri.freedesktop.org/wiki/DRM"
+license=('GPL')
+depends=('linux')
+makedepends=('linux-headers')
+optdepends=('mach64-dri: Mesa DRI drivers for Mach64'
+ 'xf86-video-mach64: X.Org Mach64 video driver')
+source=(http://trya.alwaysdata.net/linux/mach64-$pkgver.tar.gz)
+md5sums=('b763647c584bb524db3d7418651dcd4e')
+install="mach64drm.install"
+
+build() {
+ cd "$srcdir/mach64-$pkgver"
+ make
+}
+
+package() {
+ install -Dm644 "$srcdir/mach64-$pkgver/mach64.ko" \
+ "$pkgdir/usr/lib/modules/`uname -r`/kernel/drivers/gpu/drm/mach64/mach64.ko"
+}
diff --git a/mach64drm.install b/mach64drm.install
new file mode 100644
index 000000000000..b39964ad28a7
--- /dev/null
+++ b/mach64drm.install
@@ -0,0 +1,22 @@
+post_install() {
+ echo ""
+ echo "Updating modules dependencies..."
+ depmod -a `uname -r`
+ echo "Done."
+ echo ""
+ echo "Please read https://wiki.archlinux.org/index.php/Mach64"
+ echo "for the configuration of direct rendering inside Xorg."
+ echo ""
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ echo ""
+ echo "Updating modules dependencies..."
+ depmod -a `uname -r`
+ echo "Done."
+ echo ""
+}