summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristoph Fink2023-03-15 12:02:12 +0200
committerChristoph Fink2023-03-15 12:02:12 +0200
commitf0616899a8e26da16656f536788aa4bf8c85f031 (patch)
tree03c0e93e50381043023a9f02f5f79dd8e43a5801
parent7fb85419b5fd4c221837e4be60822fd615efb2d3 (diff)
downloadaur-f0616899a8e26da16656f536788aa4bf8c85f031.tar.gz
upgpkg: r-rlang 1.1.0-1
upstream release
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD41
2 files changed, 28 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index db1cbf6476d5..7cbe743817e2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
pkgbase = r-rlang
- pkgdesc = Functions for Base Types and Core R and 'Tidyverse' Features
- pkgver = 1.0.6
+ pkgdesc = Functions for Base Types and Core R and ‘Tidyverse’ Features
+ pkgver = 1.1.0
pkgrel = 1
url = https://cran.r-project.org/package=rlang
arch = i686
arch = x86_64
license = MIT
- depends = r>=3.4.0
+ depends = r>=3.5.0
optdepends = r-cli>=3.1.0
optdepends = r-covr
optdepends = r-crayon
@@ -21,7 +21,7 @@ pkgbase = r-rlang
optdepends = r-usethis
optdepends = r-vctrs>=0.2.3
optdepends = r-withr
- source = https://cran.r-project.org/src/contrib/rlang_1.0.6.tar.gz
- sha256sums = e6973d98a0ea301c0da1eeaa435e9e65d1c3f0b95ed68bdc2d6cb0c610166760
+ source = https://cran.r-project.org/src/contrib/rlang_1.1.0.tar.gz
+ b2sums = 6aad4eee4a97b7082160e2a2354c7165322a3e55e84239a38edda18eda5cbc8fdacc0bc8bbc246dfec41e9ec366d64dfe3e2e366f8d914f2b2ff9f5310582ab8
pkgname = r-rlang
diff --git a/PKGBUILD b/PKGBUILD
index 31c6ec119749..b3f4f53e19fe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,33 +3,38 @@
# Contributor: Grey Christoforo <first name at last name dot net>
_cranname=rlang
-_cranver=1.0.6
+_cranver=1.1.0
pkgname=r-${_cranname,,}
+pkgdesc="Functions for Base Types and Core R and ‘Tidyverse’ Features"
+url="https://cran.r-project.org/package=${_cranname}"
+license=("MIT")
pkgver=${_cranver//[:-]/.}
pkgrel=1
-pkgdesc="Functions for Base Types and Core R and 'Tidyverse' Features"
-arch=(i686 x86_64)
-url="https://cran.r-project.org/package=${_cranname}"
-license=(MIT)
-depends=("r>=3.4.0")
+
+arch=("i686" "x86_64")
+depends=(
+ "r>=3.5.0"
+)
optdepends=(
"r-cli>=3.1.0"
- r-covr
- r-crayon
- r-fs
- r-glue
- r-knitr
- r-magrittr
- r-pillar
- r-rmarkdown
+ "r-covr"
+ "r-crayon"
+ "r-fs"
+ "r-glue"
+ "r-knitr"
+ "r-magrittr"
+ "r-pillar"
+ "r-rmarkdown"
"r-testthat>=3.0.0"
- r-tibble
- r-usethis
+ "r-tibble"
+ "r-usethis"
"r-vctrs>=0.2.3"
- r-withr
+ "r-withr"
)
+makedepends=()
+
source=("https://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
-sha256sums=("e6973d98a0ea301c0da1eeaa435e9e65d1c3f0b95ed68bdc2d6cb0c610166760")
+b2sums=('6aad4eee4a97b7082160e2a2354c7165322a3e55e84239a38edda18eda5cbc8fdacc0bc8bbc246dfec41e9ec366d64dfe3e2e366f8d914f2b2ff9f5310582ab8')
build() {
R CMD INSTALL ${_cranname}_${_cranver}.tar.gz -l "${srcdir}"