summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIyán Méndez Veiga2022-11-29 14:37:31 +0100
committerIyán Méndez Veiga2022-11-29 14:37:31 +0100
commitf07cd7660a47baeb0f86d45c9f1f731c87d4cd13 (patch)
treea67bbf930fa0cdb902a0bb79e8c1cc55eab1a899
parent318c3a52900f08b4b84904ca0ec87094f1510f03 (diff)
downloadaur-f07cd7660a47baeb0f86d45c9f1f731c87d4cd13.tar.gz
upgpkg: jupyter-octave_kernel 0.35.1-1
upstream release
-rw-r--r--.SRCINFO8
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD18
3 files changed, 19 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1012c52e2606..30d4eae28a11 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,20 @@
pkgbase = jupyter-octave_kernel
pkgdesc = A Jupyter kernel for Octave
- pkgver = 0.34.2
+ pkgver = 0.35.1
pkgrel = 1
url = https://github.com/Calysto/octave_kernel
arch = any
license = BSD
makedepends = python-build
+ makedepends = python-hatchling
makedepends = python-installer
depends = jupyter-metakernel
depends = octave
depends = python-ipykernel
depends = python-jupyter_client
- depends = python-jupyter_packaging
optdepends = gnuplot: for making plots
optdepends = jupyterlab: JupyterLab computational environment
- source = https://github.com/Calysto/octave_kernel/archive/v0.34.2.tar.gz
- sha256sums = 912f8581a582777614e23417332bab2975afbe26d9b6a5b80a6a8b15dfb7b3b1
+ source = jupyter-octave_kernel-0.35.1.tar.gz::https://github.com/Calysto/octave_kernel/archive/v0.35.1.tar.gz
+ b2sums = 62700070fbad51cd3b27823ef1e6d2b5b0c563b4234a1318fb886e1473b3b0874a319ece85c7f31516ac95f5216858badbe7449ab6a24b337fa503e16f1c64ac
pkgname = jupyter-octave_kernel
diff --git a/.gitignore b/.gitignore
index c83a016c7bdb..df6ac04791b0 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,5 +1,5 @@
pkg/
src/
-*.tar.zst
-*.tar.gz
-*.whl
+*.log
+*.sh
+*.tar.*
diff --git a/PKGBUILD b/PKGBUILD
index b52eeeee303d..b67fb7a0c5d3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: renyuneyun <renyuneyun (at) gmail (dot) com>
_name=octave_kernel
pkgname=jupyter-${_name}
-pkgver=0.34.2
+pkgver=0.35.1
pkgrel=1
pkgdesc="A Jupyter kernel for Octave"
arch=('any')
@@ -14,12 +14,18 @@ depends=(
'octave'
'python-ipykernel'
'python-jupyter_client'
- 'python-jupyter_packaging'
)
-makedepends=('python-build' 'python-installer')
-optdepends=('gnuplot: for making plots' 'jupyterlab: JupyterLab computational environment')
-source=("https://github.com/Calysto/octave_kernel/archive/v${pkgver}.tar.gz")
-sha256sums=('912f8581a582777614e23417332bab2975afbe26d9b6a5b80a6a8b15dfb7b3b1')
+makedepends=(
+ 'python-build'
+ 'python-hatchling'
+ 'python-installer'
+)
+optdepends=(
+ 'gnuplot: for making plots'
+ 'jupyterlab: JupyterLab computational environment'
+)
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/Calysto/octave_kernel/archive/v${pkgver}.tar.gz")
+b2sums=('62700070fbad51cd3b27823ef1e6d2b5b0c563b4234a1318fb886e1473b3b0874a319ece85c7f31516ac95f5216858badbe7449ab6a24b337fa503e16f1c64ac')
build() {
cd "$srcdir"/$_name-${pkgver}