summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLatif Sulistyo2022-03-30 16:37:20 +0700
committerLatif Sulistyo2022-03-30 16:37:20 +0700
commitf0a6f8931a6e7933b3f0f574b306da57a63574c5 (patch)
tree6476931493eb9ae9dddc27427a18dd8c7ac4e2c0
downloadaur-f0a6f8931a6e7933b3f0f574b306da57a63574c5.tar.gz
Initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD34
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b4b3f6c91fa0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = awesome-rubato-git
+ pkgdesc = Create smooth animations with a slope curve for awesomeWM
+ pkgver = r62.51b4f76
+ pkgrel = 1
+ url = https://github.com/andOrlando/rubato
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = awesome
+ source = git+https://github.com/andOrlando/rubato.git
+ md5sums = SKIP
+
+pkgname = awesome-rubato-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fcfb5e5ee580
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Latif Sulistyo <latifsulistyo.me@gmail.com>
+
+# shellcheck disable=2034,2154
+# shellcheck shell=bash
+
+_pkgname=rubato
+pkgname=awesome-$_pkgname-git
+pkgver=r62.51b4f76
+pkgrel=1
+pkgdesc='Create smooth animations with a slope curve for awesomeWM'
+
+arch=('any')
+url='https://github.com/andOrlando/rubato'
+license=('MIT')
+depends=('awesome')
+makedepends=('git')
+source=('git+https://github.com/andOrlando/rubato.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname" || exit 1
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$_pkgname" || exit 1
+
+ install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
+
+ find . \
+ -type f \
+ \( -iname '*.lua' \) \
+ -exec install -Dm644 {} "$pkgdir/usr/share/awesome/lib/$_pkgname/{}" \;
+}