summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjoshcarp2023-03-29 17:22:09 -0400
committerjoshcarp2023-03-29 17:22:09 -0400
commitf0a76dd03b6069c47e6eda165972bdea9d568b8e (patch)
tree490feaa267460df2961b4b9f480d2d3fd7a1b28a
parent4825f171b8e26b5e3bf8ce7b73e1c224b12fa2a5 (diff)
downloadaur-f0a76dd03b6069c47e6eda165972bdea9d568b8e.tar.gz
Update to v1.16.0
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD22
2 files changed, 14 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2270aff34072..cb14ba1f7297 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
pkgbase = buf
pkgdesc = A new way of working with Protocol Buffers
- pkgver = 1.15.1
+ pkgver = 1.16.0
pkgrel = 1
url = https://buf.build
arch = any
license = Apache
makedepends = go
- source = https://github.com/bufbuild/buf/archive/v1.15.1.tar.gz
- sha256sums = b41e98ee5e2beecf21a90c657acdfc7a86cec3e5a60a333984ecb9184f9f5fec
+ source = https://github.com/bufbuild/buf/archive/v1.16.0.tar.gz
+ sha256sums = 813622b436554ee587c25da4c43b2f0277cc8638ee1a00c46c0bdfced57b09e4
pkgname = buf
diff --git a/PKGBUILD b/PKGBUILD
index ef35565ecd03..95b075c36ebb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,17 @@
# Maintainer: Buf <bot@buf.build>
# Contributor: Alexander Menzhinsky <amenzhinsky@gmail.com>
pkgname=buf
-pkgver=1.15.1
+pkgver=1.16.0
pkgrel=1
pkgdesc="A new way of working with Protocol Buffers"
arch=("any")
url="https://buf.build"
license=('Apache')
makedepends=('go')
-source=("https://github.com/bufbuild/buf/archive/v1.15.1.tar.gz")
+source=("https://github.com/bufbuild/buf/archive/v1.16.0.tar.gz")
build() {
- cd ${pkgname}-1.15.1
+ cd ${pkgname}-1.16.0
go build -trimpath -buildmode=pie -mod=readonly -modcacherw -buildvcs=false -o . ./cmd/{buf,protoc-gen-buf-lint,protoc-gen-buf-breaking}
./buf completion bash >completion.bash
./buf completion zsh >completion.zsh
@@ -21,13 +21,13 @@ build() {
}
package() {
- install -Dm755 "${pkgname}-1.15.1/buf" "${pkgdir}/usr/bin/buf"
- install -Dm755 "${pkgname}-1.15.1/protoc-gen-buf-lint" "${pkgdir}/usr/bin/protoc-gen-buf-lint"
- install -Dm755 "${pkgname}-1.15.1/protoc-gen-buf-breaking" "${pkgdir}/usr/bin/protoc-gen-buf-breaking"
- install -Dm644 "${pkgname}-1.15.1/completion.bash" "${pkgdir}/etc/bash_completion.d/buf"
- install -Dm644 "${pkgname}-1.15.1/completion.zsh" "${pkgdir}/usr/share/zsh/site-functions/_buf"
- install -Dm644 "${pkgname}-1.15.1/completion.fish" "${pkgdir}/usr/share/fish/vendor_completions.d/buf.fish"
- install -Dm644 "${pkgname}-1.15.1/manpages/${pkgname}"* -t "${pkgdir}/usr/share/man/man1/"
+ install -Dm755 "${pkgname}-1.16.0/buf" "${pkgdir}/usr/bin/buf"
+ install -Dm755 "${pkgname}-1.16.0/protoc-gen-buf-lint" "${pkgdir}/usr/bin/protoc-gen-buf-lint"
+ install -Dm755 "${pkgname}-1.16.0/protoc-gen-buf-breaking" "${pkgdir}/usr/bin/protoc-gen-buf-breaking"
+ install -Dm644 "${pkgname}-1.16.0/completion.bash" "${pkgdir}/etc/bash_completion.d/buf"
+ install -Dm644 "${pkgname}-1.16.0/completion.zsh" "${pkgdir}/usr/share/zsh/site-functions/_buf"
+ install -Dm644 "${pkgname}-1.16.0/completion.fish" "${pkgdir}/usr/share/fish/vendor_completions.d/buf.fish"
+ install -Dm644 "${pkgname}-1.16.0/manpages/${pkgname}"* -t "${pkgdir}/usr/share/man/man1/"
}
-sha256sums=('b41e98ee5e2beecf21a90c657acdfc7a86cec3e5a60a333984ecb9184f9f5fec')
+sha256sums=('813622b436554ee587c25da4c43b2f0277cc8638ee1a00c46c0bdfced57b09e4')