summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlphaJack2020-09-01 11:37:37 +0200
committerAlphaJack2020-09-01 11:39:18 +0200
commitf0ac8c75c33a149d2457393510aa300e16490de7 (patch)
treef7adde47ca6082c455f3a99c3846cc70bb261912
parent941ec56a9bd3c314a1dfa16f91095f4861bab7e6 (diff)
downloadaur-f0ac8c75c33a149d2457393510aa300e16490de7.tar.gz
Packaging from pre-built .deb package
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD68
-rw-r--r--gcs.desktop9
-rw-r--r--gcs.sh7
-rw-r--r--gcs.xml33
5 files changed, 27 insertions, 110 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c67f219e0d70..e2f9205cd14a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,13 @@
pkgbase = gcs
pkgdesc = WYSIWYG editor for building character sheets for GURPS 4th Edition
- pkgver = 4.10.0
+ pkgver = 4.23.1
pkgrel = 1
- url = http://gurpscharactersheet.com
- arch = any
- license = MPL
- depends = java-runtime=8
- source = http://gurpscharactersheet.com/downloads/4.10.0/gcs-4.10.0-linux.zip
- source = gcs.sh
- source = gcs.desktop
- source = gcs.xml
- sha256sums = SKIP
- sha256sums = 25042c6759fd814e23bf9139e6f6c5f93f67eec826f55825db052f4ff84ce241
- sha256sums = 5b226260250972c1244f11be73c98bf43d3f30f428843c823c5a8a0ba01494ba
- sha256sums = cddee2d3b844dddd3a346a7c15c26f76019c875cccc03b0be34489c4dd71a320
+ url = https://gurpscharactersheet.com
+ arch = x86_64
+ license = MPL-2.0
+ depends = java-runtime
+ source = gcs-4.23.1.deb::https://github.com/richardwilkes/gcs/releases/download/v4.23.1/gcs_4.23.1-1_amd64.deb
+ md5sums = 61cc4023636c580fe012367d198f21d5
pkgname = gcs
diff --git a/PKGBUILD b/PKGBUILD
index c55c36fea5de..265a4a40645d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,54 +1,26 @@
-# Maintainer: Maxwell Anselm <silverhammermba+aur@gmail.com>
+# Maintainer: AlphaJack <alphajack at tuta dot io>
+# Contributor: Maxwell Anselm
pkgname=gcs
-pkgver=4.10.0
+pkgver=4.23.1
pkgrel=1
pkgdesc="WYSIWYG editor for building character sheets for GURPS 4th Edition"
-arch=('any')
-url="http://gurpscharactersheet.com"
-license=('MPL')
-depends=('java-runtime=8')
-source=(
- "http://gurpscharactersheet.com/downloads/$pkgver/$pkgname-$pkgver-linux.zip"
- 'gcs.sh'
- 'gcs.desktop'
- 'gcs.xml'
-)
-sha256sums=(
- 'SKIP'
- '25042c6759fd814e23bf9139e6f6c5f93f67eec826f55825db052f4ff84ce241'
- '5b226260250972c1244f11be73c98bf43d3f30f428843c823c5a8a0ba01494ba'
- 'cddee2d3b844dddd3a346a7c15c26f76019c875cccc03b0be34489c4dd71a320'
-)
-
-package() {
- pushd "$srcdir/$pkgname-$pkgver-linux"
-
- # jars
- install -d "$pkgdir/usr/share/java/gcs"
- find support/jars -name '*.jar' -execdir install -m644 {} "$pkgdir/usr/share/java/gcs" \;
-
- # library
- install -d "$pkgdir/usr/share/gcs"
- cp -dr --no-preserve=ownership Library "$pkgdir/usr/share/gcs"
-
- # icon
- install -d "$pkgdir/usr/share/icons/hicolor/128x128/apps"
- install -m644 support/gcs.png "$pkgdir/usr/share/icons/hicolor/128x128/apps/gcs.png"
-
- popd
-
- # launcher
- install -Dm755 "$srcdir/gcs.sh" "$pkgdir/usr/bin/gcs"
-
- # MIME info
- install -d "$pkgdir/usr/share/mime/packages"
- install -m644 "$srcdir/gcs.xml" "$pkgdir/usr/share/mime/packages"
-
- # .desktop
- install -d "$pkgdir/usr/share/applications"
- install -m644 "$srcdir/gcs.desktop" "$pkgdir/usr/share/applications"
+arch=("x86_64")
+url="https://gurpscharactersheet.com"
+license=("MPL-2.0")
+depends=("java-runtime")
+source=("$pkgname-$pkgver.deb::https://github.com/richardwilkes/gcs/releases/download/v$pkgver/gcs_$pkgver-1_amd64.deb")
+md5sums=("61cc4023636c580fe012367d198f21d5")
+
+prepare(){
+ tar -xvf data.tar.xz
+ sed -i "s|Icon=/opt/gcs/lib/GCS.png|Icon=gcs|" "opt/gcs/lib/gcs-GCS.desktop"
+}
- # remove version from filename
- mv "$pkgdir/usr/share/java/gcs/gcs-${pkgver}.jar" "$pkgdir/usr/share/java/gcs/gcs.jar"
+package(){
+ cp -r "opt" "$pkgdir"
+ install -d "$pkgdir/usr/share/applications"
+ install -d "$pkgdir/usr/share/pixmaps"
+ install "opt/gcs/lib/gcs-GCS.desktop" "$pkgdir/usr/share/applications/gcs.desktop"
+ install "opt/gcs/lib/GCS.png" "$pkgdir/usr/share/pixmaps/gcs.png"
}
diff --git a/gcs.desktop b/gcs.desktop
deleted file mode 100644
index 65962bbb5fb0..000000000000
--- a/gcs.desktop
+++ /dev/null
@@ -1,9 +0,0 @@
-[Desktop Entry]
-Version=1.0
-Type=Application
-Name=GURPS Character Sheet
-Exec=/usr/bin/gcs %F
-Icon=gcs
-MimeType=application/x-gurps-advantage;application/x-gurps-equipment;application/x-gurps-character;application/x-gurps-template;application/x-gurps-skill;application/x-gurps-spell;
-Categories=Game;RolePlaying;Utility;
-Keywords=Roleplaying;
diff --git a/gcs.sh b/gcs.sh
deleted file mode 100644
index b5a77303cbc4..000000000000
--- a/gcs.sh
+++ /dev/null
@@ -1,7 +0,0 @@
-#!/bin/sh
-if ! /usr/bin/java -version 2>&1 | grep 'version "1.8' >/dev/null
-then
- echo "GURPS character sheet requires Java 8" >&2
- exit 1
-fi
-GCS_LIBRARY=/usr/share/gcs exec /usr/bin/java -jar '/usr/share/java/gcs/gcs.jar' "$@"
diff --git a/gcs.xml b/gcs.xml
deleted file mode 100644
index acbcebe1e4bc..000000000000
--- a/gcs.xml
+++ /dev/null
@@ -1,33 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<mime-info xmlns="http://www.freedesktop.org/standards/shared-mime-info">
- <mime-type type="application/x-gurps-advantage">
- <sub-class-of type="text/xml"/>
- <comment>GURPS advantage list</comment>
- <glob pattern="*.adq"/>
- </mime-type>
- <mime-type type="application/x-gurps-equipment">
- <sub-class-of type="text/xml"/>
- <comment>GURPS equipment list</comment>
- <glob pattern="*.eqp"/>
- </mime-type>
- <mime-type type="application/x-gurps-character">
- <sub-class-of type="text/xml"/>
- <comment>GURPS character sheet</comment>
- <glob pattern="*.gcs"/>
- </mime-type>
- <mime-type type="application/x-gurps-template">
- <sub-class-of type="text/xml"/>
- <comment>GURPS character template</comment>
- <glob pattern="*.gct"/>
- </mime-type>
- <mime-type type="application/x-gurps-skill">
- <sub-class-of type="text/xml"/>
- <comment>GURPS skill list</comment>
- <glob pattern="*.skl"/>
- </mime-type>
- <mime-type type="application/x-gurps-spell">
- <sub-class-of type="text/xml"/>
- <comment>GURPS spell list</comment>
- <glob pattern="*.spl" weight="55"/>
- </mime-type>
-</mime-info>