summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUniversebenzene2023-07-05 11:29:27 +0800
committerUniversebenzene2023-07-05 11:29:27 +0800
commitf0db6bfa2d21de449648a33fff67089b0b6b4547 (patch)
tree97b41c6d6cc0176507286b4299c119d4b001cd84
parent57c2d108da8291b580b99434a832f96fbdac695f (diff)
downloadaur-f0db6bfa2d21de449648a33fff67089b0b6b4547.tar.gz
Update to version 1.16.3
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD9
2 files changed, 9 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b577428ca7c8..d3920fc02841 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-healpy
pkgdesc = Python package to manipulate healpix maps
- pkgver = 1.16.2
+ pkgver = 1.16.3
pkgrel = 1
url = http://healpy.readthedocs.io
arch = i686
@@ -8,13 +8,12 @@ pkgbase = python-healpy
license = GPL
checkdepends = python-pytest-cython
checkdepends = python-pytest-doctestplus
- checkdepends = python-requests
makedepends = python-setuptools
makedepends = cython
makedepends = python-wheel
makedepends = python-build
makedepends = python-installer
- depends = python>=3.7
+ depends = python>=3.8
depends = python-numpy>=1.13
depends = python-scipy
depends = python-matplotlib
@@ -22,7 +21,7 @@ pkgbase = python-healpy
depends = cfitsio>=4.1.0
depends = healpix>=3.80
optdepends = python-healpy-doc: Documentation for healpy
- source = https://files.pythonhosted.org/packages/source/h/healpy/healpy-1.16.2.tar.gz
- md5sums = ff3015917f100cd7ff058220a7c088c4
+ source = https://files.pythonhosted.org/packages/source/h/healpy/healpy-1.16.3.tar.gz
+ md5sums = 11ac43c53f1f935004393bde55667f9e
pkgname = python-healpy
diff --git a/PKGBUILD b/PKGBUILD
index 4333d32ca0b3..d81ebefa0519 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,22 +2,23 @@
pkgname=python-healpy
_pyname=${pkgname#python-}
-pkgver=1.16.2
+pkgver=1.16.3
pkgrel=1
pkgdesc="Python package to manipulate healpix maps"
arch=('i686' 'x86_64')
url="http://healpy.readthedocs.io"
license=('GPL')
-depends=('python>=3.7' 'python-numpy>=1.13' 'python-scipy' 'python-matplotlib' 'python-astropy' 'cfitsio>=4.1.0' 'healpix>=3.80')
+depends=('python>=3.8' 'python-numpy>=1.13' 'python-scipy' 'python-matplotlib' 'python-astropy' 'cfitsio>=4.1.0' 'healpix>=3.80')
makedepends=('python-setuptools'
'cython'
'python-wheel'
'python-build'
'python-installer')
optdepends=('python-healpy-doc: Documentation for healpy')
-checkdepends=('python-pytest-cython' 'python-pytest-doctestplus' 'python-requests')
+checkdepends=('python-pytest-cython'
+ 'python-pytest-doctestplus') # requests -> pooch -> scipy
source=("https://files.pythonhosted.org/packages/source/h/healpy/healpy-${pkgver}.tar.gz")
-md5sums=('ff3015917f100cd7ff058220a7c088c4')
+md5sums=('11ac43c53f1f935004393bde55667f9e')
get_pyver() {
python -c "import sys; print('$1'.join(map(str, sys.version_info[:2])))"