summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoakim Repomaa2020-05-10 13:32:38 +0200
committerJoakim Repomaa2020-05-10 13:32:38 +0200
commitf1101f27d9b60a95d8259630c3654a3ccbcd0eb2 (patch)
treeed7343184bae447508d58b90c5c9028844e13dfd
parentc555afc9fb80726c7181402f838f01e03bc8282c (diff)
downloadaur-f1101f27d9b60a95d8259630c3654a3ccbcd0eb2.tar.gz
update to 0.2.4
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD19
2 files changed, 10 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 29ed95d168cd..e8a56a240600 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Fri Nov 22 14:03:37 UTC 2019
pkgbase = autopass.cr
pkgdesc = a rofi frontend for pass
- pkgver = 0.2.2
+ pkgver = 0.2.4
pkgrel = 1
url = https://gitlab.com/repomaa/autopass.cr
arch = x86_64
@@ -19,18 +17,13 @@ pkgbase = autopass.cr
depends = gc
depends = libyaml
depends = libevent
+ depends = dbus
optdepends = passed-git: batch editing of pass entries with sed
- provides = autopass
conflicts = autopass
conflicts = autopass.cr-git
conflicts = autopass.cr-bin
- source = https://gitlab.com/repomaa/autopass.cr//uploads/ef41eabeca18c38439ecda45ebd198d4/autopass.cr-v0.2.2.tar.gz
- source = https://gitlab.com/repomaa/autopass.cr//uploads/a9f00047a3bcb06e832f30e221ea5fcd/autopass.cr-v0.2.2.tar.gz.sig
- source = autopass.socket
- source = autopass.service
- md5sums = 86dcbd460c13690e07f2871a142207cd
- md5sums = SKIP
- md5sums = SKIP
+ source = git+https://gitlab.com/repomaa/autopass.cr?signed#tag=v0.2.4
+ validpgpkeys = F0AF1CE34733B22317A8937D05557F53CD3C6458
md5sums = SKIP
pkgname = autopass.cr
diff --git a/PKGBUILD b/PKGBUILD
index 67695ca1a6d9..bce6f1c336cf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,39 +1,32 @@
# Maintainer: Joakim Repomaa <aur@j.repomaa.com>
pkgname=autopass.cr
-pkgver=0.2.2
+pkgver=0.2.4
pkgrel=1
pkgdesc='a rofi frontend for pass'
arch=(x86_64)
url='https://gitlab.com/repomaa/autopass.cr'
license=('MIT')
-depends=(pass rofi xdotool gpgme gc libyaml libevent)
+depends=(pass rofi xdotool gpgme gc libyaml libevent dbus)
makedepends=(crystal shards rust git python)
source=(
- 'https://gitlab.com/repomaa/autopass.cr//uploads/ef41eabeca18c38439ecda45ebd198d4/autopass.cr-v0.2.2.tar.gz'
- 'https://gitlab.com/repomaa/autopass.cr//uploads/a9f00047a3bcb06e832f30e221ea5fcd/autopass.cr-v0.2.2.tar.gz.sig'
- 'autopass.socket'
- 'autopass.service'
+ "git+https://gitlab.com/repomaa/autopass.cr?signed#tag=v${pkgver}"
)
md5sums=(
- 86dcbd460c13690e07f2871a142207cd
- SKIP
- SKIP
SKIP
)
-validpgpkeys=(CC7BD43A315EBC373F9A1F2EEFEB16CB1C8952C5)
-provides=('autopass')
+validpgpkeys=(F0AF1CE34733B22317A8937D05557F53CD3C6458)
conflicts=('autopass' 'autopass.cr-git' 'autopass.cr-bin')
optdepends=('passed-git: batch editing of pass entries with sed')
build() {
- cd "${pkgname}-v${pkgver}"
+ cd "${pkgname}"
shards build --release
}
package() {
- cd "${pkgname}-v${pkgver}"
+ cd "${pkgname}"
install -Dm755 bin/autopass "$pkgdir/usr/bin/autopass"
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
install -Dm644 autopass.socket "$pkgdir/usr/lib/systemd/user/autopass.socket"