summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornl67202024-03-21 14:02:00 +0200
committernl67202024-03-21 14:04:15 +0200
commitf161157469d7424bde94e2fd1e0c1b89801c5479 (patch)
tree2b184334db89ec7ea9aa1d0e80a5a9c4aed06fbf
parent090900613468f2be4ea6bfbaff026425d2b3ecf2 (diff)
downloadaur-f161157469d7424bde94e2fd1e0c1b89801c5479.tar.gz
shim-signed 15.8+ubuntu+1.57-1
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD27
2 files changed, 30 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dda85a71ed30..c84af6c96621 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,19 @@
pkgbase = shim-signed
- pkgdesc = Initial UEFI bootloader that handles chaining to a trusted full bootloader under secure boot environments (prebuilt x64 binaries from Ubuntu)
- pkgver = 15.7+ubuntu+1.56
+ pkgdesc = Initial UEFI bootloader that handles chaining to a trusted full bootloader under secure boot environments (prebuilt x64 and AA64 binaries from Ubuntu)
+ pkgver = 15.8+ubuntu+1.57
pkgrel = 1
url = https://packages.ubuntu.com/noble/shim-signed
install = shim-signed.install
arch = any
- license = BSD
+ license = BSD-2-Clause
+ noextract = shim-signed_1.57+15.8-0ubuntu1_arm64.deb
options = !strip
- source = http://archive.ubuntu.com/ubuntu/pool/main/s/shim-signed/shim-signed_1.56+15.7-0ubuntu1_amd64.deb
- sha256sums = b2d84b300e68ac2139afee3f9a609857ef80f12eed9218087ced4b31ecb7fd76
- sha512sums = 43ee11ec0ed04f224fb7452b2baaca45882a719063879f423c4118b6b99e99fd3fb20fa1a7de02af7b885f4d5c5e86e9868fb41557e74c52fbf04e3988199bd6
+ options = !debug
+ source = http://archive.ubuntu.com/ubuntu/pool/main/s/shim-signed/shim-signed_1.57+15.8-0ubuntu1_amd64.deb
+ source = http://ports.ubuntu.com/pool/main/s/shim-signed/shim-signed_1.57+15.8-0ubuntu1_arm64.deb
+ sha256sums = 532a97f7376ac8e5d7bedb8b2d4283769251266d19a78e3e12ec44f53a1dab6a
+ sha256sums = 5f942542c21c41ffa14d22b890a6f51ccbfa0b3231f8a475265f90cb6e1cb924
+ sha512sums = de1c60b442d7484aa210c308ca422fe0d93439b50aeba192d2bbec7ec4d92779355d6ca838bb3d221fad8c4ea343dae37c13606200daf6f8f1436b120a4e9690
+ sha512sums = ed0c856460c5a2aef8d9c4214ee9f2ba0c4926c4efec8add7171c0adada68f6c87f43461d67f8ca8747e9eaa037b2b90810d8daebecbc1c3a67bea34f781ea3e
pkgname = shim-signed
diff --git a/PKGBUILD b/PKGBUILD
index e7fa10464700..4b715c928cbb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,36 @@
# Maintainer: nl6720 <nl6720@archlinux.org>
pkgname='shim-signed'
-pkgver='15.7+ubuntu+1.56'
+pkgver='15.8+ubuntu+1.57'
pkgrel='1'
-pkgdesc='Initial UEFI bootloader that handles chaining to a trusted full bootloader under secure boot environments (prebuilt x64 binaries from Ubuntu)'
+pkgdesc='Initial UEFI bootloader that handles chaining to a trusted full bootloader under secure boot environments (prebuilt x64 and AA64 binaries from Ubuntu)'
url='https://packages.ubuntu.com/noble/shim-signed'
arch=('any')
-license=('BSD')
-options=('!strip')
+license=('BSD-2-Clause')
+options=('!strip' '!debug')
install="${pkgname}.install"
-source=("http://archive.ubuntu.com/ubuntu/pool/main/s/shim-signed/shim-signed_${pkgver##*+ubuntu+}+${pkgver%%+ubuntu*}-0ubuntu1_amd64.deb")
-sha256sums=('b2d84b300e68ac2139afee3f9a609857ef80f12eed9218087ced4b31ecb7fd76')
-sha512sums=('43ee11ec0ed04f224fb7452b2baaca45882a719063879f423c4118b6b99e99fd3fb20fa1a7de02af7b885f4d5c5e86e9868fb41557e74c52fbf04e3988199bd6')
+source=("http://archive.ubuntu.com/ubuntu/pool/main/s/shim-signed/shim-signed_${pkgver##*+ubuntu+}+${pkgver%%+ubuntu*}-0ubuntu1_amd64.deb"
+ "http://ports.ubuntu.com/pool/main/s/shim-signed/shim-signed_${pkgver##*+ubuntu+}+${pkgver%%+ubuntu*}-0ubuntu1_arm64.deb")
+noextract=("shim-signed_${pkgver##*+ubuntu+}+${pkgver%%+ubuntu*}-0ubuntu1_arm64.deb")
+sha256sums=('532a97f7376ac8e5d7bedb8b2d4283769251266d19a78e3e12ec44f53a1dab6a'
+ '5f942542c21c41ffa14d22b890a6f51ccbfa0b3231f8a475265f90cb6e1cb924')
+sha512sums=('de1c60b442d7484aa210c308ca422fe0d93439b50aeba192d2bbec7ec4d92779355d6ca838bb3d221fad8c4ea343dae37c13606200daf6f8f1436b120a4e9690'
+ 'ed0c856460c5a2aef8d9c4214ee9f2ba0c4926c4efec8add7171c0adada68f6c87f43461d67f8ca8747e9eaa037b2b90810d8daebecbc1c3a67bea34f781ea3e')
prepare() {
+ local debfile
+
cd "$srcdir"
bsdtar -xf data.tar.xz
+ for debfile in ${noextract[@]}; do
+ bsdtar -xOf "$debfile" data.tar.xz | bsdtar -x usr/lib/shim/
+ done
}
+
package() {
install -Dm0644 "${srcdir}/usr/lib/shim/shimx64.efi.signed.latest" "${pkgdir}/usr/share/${pkgname}/shimx64.efi"
- install -Dm0644 "${srcdir}/usr/lib/shim/"{mm,fb}x64.efi "${pkgdir}/usr/share/${pkgname}/"
+ install -Dm0644 "${srcdir}/usr/lib/shim/shimaa64.efi.signed.latest" "${pkgdir}/usr/share/${pkgname}/shimaa64.efi"
+ install -Dm0644 "${srcdir}/usr/lib/shim/"{mm,fb}{x64,aa64}".efi" "${pkgdir}/usr/share/${pkgname}/"
install -Dm0644 "${srcdir}/usr/share/doc/shim-signed/copyright" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}