summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFranco Masotti2017-03-09 15:07:55 +0100
committerFranco Masotti2017-03-09 15:07:55 +0100
commitf167ae8afd9f964de7f4615d5bd70ec79765edcd (patch)
treecb2ece472bd82f0cddd14b34d9f59a108ad36107
parentd0e694896039fc52ecc3ebaa5e026e497d15517d (diff)
downloadaur-f167ae8afd9f964de7f4615d5bd70ec79765edcd.tar.gz
Updated to new version.
-rw-r--r--PKGBUILD10
-rw-r--r--rserve-sandbox-docker.service10
-rwxr-xr-xrun.sh4
3 files changed, 15 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 53e9ba909fc9..052e98510281 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,17 @@
# Contributor: Franco Masotti <franco dot masotti at student dot unife dot it>
pkgname=rserve-sandbox-docker-bin
pkgver=r6.fb0ec65
-pkgrel=1
+pkgrel=2
pkgdesc="Pre-compiled version of a Docker spec for running Rserve in a sandbox"
arch=('x86_64')
url="https://gitlab.com/frnmst/rserve-sandbox-bin"
license=('BSD')
-depends=('r'
- 'docker')
+depends=('bash'
+ 'coreutils'
+ 'docker'
+ 'gawk'
+ 'make'
+ 'r')
makedepends=('git'
'sed')
conflicts=('rserve-sandbox-docker')
diff --git a/rserve-sandbox-docker.service b/rserve-sandbox-docker.service
index d655e1da0fc1..add10c7f9d5e 100644
--- a/rserve-sandbox-docker.service
+++ b/rserve-sandbox-docker.service
@@ -3,24 +3,26 @@
#
# Copyright (C) 2016 frnmst (Franco Masotti) <franco.masotti@student.unife.it>
#
-# This file is part of cplint-installer.
+# This file is part of swish-installer.
#
-# cplint-installer is free software: you can redistribute it and/or modify
+# swish-installer is free software: you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
# the Free Software Foundation, either version 3 of the License, or
# (at your option) any later version.
#
-# cplint-installer is distributed in the hope that it will be useful,
+# swish-installer is distributed in the hope that it will be useful,
# but WITHOUT ANY WARRANTY; without even the implied warranty of
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
# GNU General Public License for more details.
#
# You should have received a copy of the GNU General Public License
-# along with cplint-installer. If not, see <http://www.gnu.org/licenses/>.
+# along with swish-installer. If not, see <http://www.gnu.org/licenses/>.
#
#
# To be placed in /usr/lib/systemd/system/rserve-sandbox-docker.service
+# or /lib/systemd/system/rserve-sandbox-docker.service
+# depending on your GNU/Linux distribution
[Unit]
Description=Docker spec for running Rserve in a sandbox
diff --git a/run.sh b/run.sh
index 45cd57e9f7d0..ef81a8a8d7f6 100755
--- a/run.sh
+++ b/run.sh
@@ -1,4 +1,4 @@
-#!/usr/bin/env sh
+#!/usr/bin/env bash
#
# run.sh
@@ -77,7 +77,7 @@ killd()
# kill action only if process exists.
if [ -f "$pid_file" ]; then
pid=$(cat "$pid_file")
- ps -q $pid > /dev/null
+ ps -p $pid > /dev/null
if [ $? -eq 0 ]; then
make -C "$pkg_dir" stop
fi