summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorROllerozxa2021-08-18 12:44:47 +0200
committerROllerozxa2021-08-18 12:44:47 +0200
commitf1745662c99f5a3abfd897b5dd47bb3f2c249431 (patch)
treee90b37dbdfee5112664dfa0cde8d19a54cb6b814
parente831e4751aefc7b7016726a8963cdf90f1918b79 (diff)
downloadaur-f1745662c99f5a3abfd897b5dd47bb3f2c249431.tar.gz
Update package.
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD56
-rw-r--r--lunar-magic.pngbin634 -> 466 bytes
3 files changed, 40 insertions, 36 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d252f748867c..a7e582eb51a0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,21 @@
pkgbase = lunar-magic
pkgdesc = Level editor for Super Mario World
- pkgver = 3.11
- pkgrel = 7
+ pkgver = 3.30
+ pkgrel = 2
url = https://fusoya.eludevisibility.org/lm/index.html
- arch = any
+ arch = i686
+ arch = x86_64
license = custom
makedepends = unzip
depends = wine
- noextract = lm311.zip
- source = https://fusoya.eludevisibility.org/lm/download/lm311.zip
+ noextract = lm330.zip
+ source = https://fusoya.eludevisibility.org/lm/download/lm330.zip
source = lunar-magic
source = lunar-magic.desktop
source = lunar-magic.png
- md5sums = 697a178456a25bdb0a4416639d3ef7cd
- md5sums = b962597de58d7341a7b5fbacc264f933
- md5sums = 21524585562254d81b837b13e2012e2e
- md5sums = 2d08cd1860ee8cc1bf82bcc0dca4ba70
+ sha256sums = ac27a9cd61946d6ec4cd7414cd8a1de057bfca3de3e06fc9b3be194445050dc2
+ sha256sums = c1f2ef084107f4947b008bc6fbd6da820b48568a20229ebaaaf5834e31b4ce89
+ sha256sums = 33fa325303281102f1fa875053ea84ef50d2adff510d7a17efc9c2df72975efa
+ sha256sums = 91317fb39eb5f92dbc11e74bb2179832e8f254c40ecabb16c11cbf0fddd45fad
pkgname = lunar-magic
-
diff --git a/PKGBUILD b/PKGBUILD
index ed0a249d8055..665b95cf1399 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,37 @@
-# Maintainer: ConfuZzled <theconfuzzleddude@gmail.com>
-pkgname='lunar-magic'
-pkgver=3.11
-pkgrel=7
+# Maintainer: ROllerozxa <temporaryemail4meh [gee mail]>
+# Contributor: ConfuZzled <theconfuzzleddude@gmail.com>
+pkgname=lunar-magic
+pkgver=3.30
+_pkgver=330
+pkgrel=2
pkgdesc='Level editor for Super Mario World'
url='https://fusoya.eludevisibility.org/lm/index.html'
-arch=(any)
-depends=(wine)
-makedepends=(unzip)
-source=(https://fusoya.eludevisibility.org/lm/download/lm311.zip lunar-magic lunar-magic.desktop lunar-magic.png)
-noextract=('lm311.zip')
-md5sums=('697a178456a25bdb0a4416639d3ef7cd'
- 'b962597de58d7341a7b5fbacc264f933'
- '21524585562254d81b837b13e2012e2e'
- '2d08cd1860ee8cc1bf82bcc0dca4ba70')
+arch=('i686' 'x86_64')
+depends=('wine')
+makedepends=('unzip')
+source=("https://fusoya.eludevisibility.org/lm/download/lm${_pkgver}.zip"
+ "${pkgname}"
+ "${pkgname}.desktop"
+ "${pkgname}.png")
+noextract=("lm${_pkgver}.zip")
+sha256sums=('ac27a9cd61946d6ec4cd7414cd8a1de057bfca3de3e06fc9b3be194445050dc2'
+ 'c1f2ef084107f4947b008bc6fbd6da820b48568a20229ebaaaf5834e31b4ce89'
+ '33fa325303281102f1fa875053ea84ef50d2adff510d7a17efc9c2df72975efa'
+ '91317fb39eb5f92dbc11e74bb2179832e8f254c40ecabb16c11cbf0fddd45fad')
license=('custom')
-
package() {
- cd $srcdir
- install -d -m755 $pkgdir/usr/share/lunar-magic
- unzip lm311.zip -d $pkgdir/usr/share/lunar-magic
- sed -n '/The Lunar Magic Mario/,/ use or presence./p' $pkgdir/usr/share/lunar-magic/readme.txt >> LICENSE
+ install -d -m755 "${pkgdir}/usr/share/${pkgname}"
+ unzip "lm${_pkgver}.zip" -d "${pkgdir}/usr/share/${pkgname}"
+
+ # extract license from readme
+ sed -n '/The Lunar Magic Mario/,/ use or presence./p' "${pkgdir}/usr/share/${pkgname}/readme.txt" >> 'LICENSE'
+ install -Dm644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+
+ install -Dm755 "${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
+ install -Dm644 "${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+ install -Dm644 "${pkgname}.png" "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
- install -Dm755 lunar-magic $pkgdir/usr/bin/lunar-magic
- install -Dm644 lunar-magic.desktop $pkgdir/usr/share/applications/lunar-magic.desktop
- install -Dm644 lunar-magic.png $pkgdir/usr/share/pixmaps/lunar-magic.png
-
-
- find $pkgdir/usr/share/lunar-magic -type d -exec chmod 755 "{}" \;
- find $pkgdir/usr/share/lunar-magic -type f -exec chmod 644 "{}" \;
+ find "${pkgdir}/usr/share/${pkgname}" -type d -exec chmod 755 "{}" \;
+ find "${pkgdir}/usr/share/${pkgname}" -type f -exec chmod 644 "{}" \;
}
diff --git a/lunar-magic.png b/lunar-magic.png
index b31a7ada5f8d..7bafc3ce2a5c 100644
--- a/lunar-magic.png
+++ b/lunar-magic.png
Binary files differ