summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Perl2021-08-16 19:45:47 +0200
committerThomas Perl2021-08-16 19:45:47 +0200
commitf1843c45d1a6e86450afc8af81b661ae7fd02227 (patch)
treef519067986e44510bac196fb051a3a39b550c5aa
downloadaur-f1843c45d1a6e86450afc8af81b661ae7fd02227.tar.gz
Package chro.mono for Arch Linux
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD24
3 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..56ae01c179f7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = chromono
+ pkgdesc = A very circular color puzzle game
+ pkgver = 1.1.0
+ pkgrel = 1
+ url = https://thp.io/2013/chromono/
+ arch = x86_64
+ license = GPL
+ makedepends = cmake
+ makedepends = python3
+ depends = sdl2
+ depends = zlib
+ depends = libvorbis
+ depends = libglvnd
+ source = https://thp.io/2013/chromono/chromono-1.1.0.tar.gz
+ sha256sums = 9a15fa795e4f14ef8683c5ddaf1b6c115fda306957c97604fc4f117599c9f2ae
+
+pkgname = chromono
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..5eeaebf76b27
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/pkg
+/src
+*.pkg.tar.zst
+*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..91153abad000
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+pkgname=chromono
+pkgver=1.1.0
+pkgrel=1
+pkgdesc="A very circular color puzzle game"
+arch=('x86_64')
+url=https://thp.io/2013/chromono/
+license=('GPL')
+depends=('sdl2' 'zlib' 'libvorbis' 'libglvnd')
+makedepends=('cmake' 'python3')
+source=("https://thp.io/2013/$pkgname/$pkgname-$pkgver.tar.gz")
+sha256sums=('9a15fa795e4f14ef8683c5ddaf1b6c115fda306957c97604fc4f117599c9f2ae')
+
+build() {
+ cd ${pkgname}-${pkgver}
+ cmake -B build -DCMAKE_INSTALL_PREFIX=/usr .
+ make -C build
+}
+
+package() {
+ cd ${pkgname}-${pkgver}
+ make -C build install DESTDIR="${pkgdir}/"
+}
+
+# vim:set ts=2 sw=2 et: