aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbadetitou2021-08-19 18:51:27 +0200
committerbadetitou2021-08-19 18:51:27 +0200
commitf1b544055a2b5007cc7e98d1b46a262541739fed (patch)
tree90a92d97928bf9556573c0e0fd6eb17fdc4e76e7
parentce6ae948bf5122c831b5d7438caacca5ce9f3a21 (diff)
downloadaur-f1b544055a2b5007cc7e98d1b46a262541739fed.tar.gz
add launcher patch
-rw-r--r--PKGBUILD6
-rw-r--r--launcher-patch.st27
2 files changed, 32 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3a9376b19483..0610abccb372 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=pharo-launcher
epoch=1
pkgver=2.3
-pkgrel=0
+pkgrel=1
pkgdesc="Pharo Launcher helps you manage your Pharo images"
arch=(x86_64)
source=(PharoLauncher-linux-$pkgver.zip pharo.conf)
@@ -17,11 +17,13 @@ makedepends=('gendesk' 'libcurl-gnutls')
source=(
"http://files.pharo.org/pharo-launcher/$pkgver/PharoLauncher-linux-$pkgver-x64.zip"
'local://pharo.conf'
+ 'local://launcher-patch.st'
)
md5sums=(
'2f08268f47bbdd231fc28d51ab46a521'
'b2e30a17b522ee265fd57fe7c45592fc'
+ 'aca22ab459484bfd21d91d5ddc1989c8'
)
prepare() {
@@ -60,4 +62,6 @@ package() {
mkdir -p $pkgdir/etc/security/limits.d/
cp $srcdir/pharo.conf $pkgdir/etc/security/limits.d/pharo.conf
+ $pkgdir/usr/share/pharo-vm/pharo $pkgdir/usr/share/pharo-launcher/PharoLauncher.image st $srcdir/launcher-patch.st
+
}
diff --git a/launcher-patch.st b/launcher-patch.st
new file mode 100644
index 000000000000..2d7ccd1551e5
--- /dev/null
+++ b/launcher-patch.st
@@ -0,0 +1,27 @@
+PhLVmProvider subclass: #PhLVmProviderArchlinux90
+ instanceVariableNames: ''
+ classVariableNames: ''
+ package: 'PharoLauncher-Core-Download-Arch'.
+
+PhLVmProviderArchlinux90 compile: 'urlTemplate
+ ^ ''https://badetitou.github.io/files/archlinux/90-x64-Arch.zip'''.
+
+PhLVmProviderArchlinux90 compile: 'urlForStable: useStableVm
+ ^ self urlTemplate'.
+
+PhLVmProviderArchlinux90 compile: 'urlForPharo: pharoVersion stable: useStableVm
+ ^ self urlTemplate'.
+
+PhLVmProvider class compile: 'for: aPhLVirtualMachineOrManager
+ | class |
+ class := aPhLVirtualMachineOrManager pharoVersion asInteger < 90
+ ifTrue: [ PhLVmProviderUntilPharo80 ]
+ ifFalse: [ aPhLVirtualMachineOrManager pharoVersion asInteger < 100
+ ifTrue: [ PhLVmProviderArchlinux90 ]
+ ifFalse: [ self ] ].
+ ^ class new
+ vmManager: aPhLVirtualMachineOrManager;
+ yourself'.
+
+
+Smalltalk snapshot: true andQuit: true \ No newline at end of file