summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHMH2021-03-10 12:26:10 +0100
committerHMH2021-03-10 12:26:10 +0100
commitf1cce7fe8942a9cc60c9947184057cd50afe270d (patch)
tree747073dd5bbf876405f820688cd060eef37ade27
downloadaur-f1cce7fe8942a9cc60c9947184057cd50afe270d.tar.gz
v0.10.0
-rw-r--r--.SRCINFO30
-rw-r--r--PKGBUILD27
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..17c5da2b5ca0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,30 @@
+pkgbase = weylus
+ pkgdesc = Use your tablet as graphic tablet/touch screen on your computer.
+ pkgver = 0.10.0
+ pkgrel = 1
+ url = https://github.com/H-M-H/Weylus
+ arch = x86_64
+ license = AGPL3
+ makedepends = rust
+ makedepends = typescript
+ makedepends = gcc
+ makedepends = libx11
+ makedepends = pkg-config
+ makedepends = git
+ makedepends = make
+ makedepends = cmake
+ depends = libxtst
+ depends = libxcursor
+ depends = libxinerama
+ depends = libxft
+ depends = libxrandr
+ depends = libxcomposite
+ depends = libdrm
+ depends = libva
+ depends = ffmpeg
+ conflicts = weylus-bin
+ source = weylus-0.10.0.zip::https://github.com/H-M-H/Weylus/archive/v0.10.0.zip
+ sha256sums = ee207946fb25df4317276c4b5e0da881142b082471afb67a255c64572c314ae9
+
+pkgname = weylus
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..be0c148f58d5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: HMH <henry@freedesk.net>
+
+pkgname=weylus
+pkgver=0.10.0
+pkgrel=1
+pkgdesc="Use your tablet as graphic tablet/touch screen on your computer."
+arch=('x86_64')
+url="https://github.com/H-M-H/Weylus"
+license=('AGPL3')
+conflicts=('weylus-bin')
+source=("$pkgname-$pkgver.zip::https://github.com/H-M-H/Weylus/archive/v$pkgver.zip")
+sha256sums=('ee207946fb25df4317276c4b5e0da881142b082471afb67a255c64572c314ae9')
+
+makedepends=(rust typescript gcc libx11 pkg-config git make cmake)
+
+build() {
+ cd "Weylus-$pkgver"
+ cargo build --release --features="ffmpeg-system"
+}
+
+package() {
+ cd "Weylus-$pkgver"
+ install -vDm755 "target/release/weylus" "$pkgdir/usr/bin/weylus"
+ install -vDm755 "weylus.desktop" "${pkgdir}/usr/share/applications/weylus.desktop"
+}
+
+depends=(libxtst libxcursor libxinerama libxft libxrandr libxcomposite libdrm libva ffmpeg)