summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2022-07-28 22:19:04 -0500
committerLuis Martinez2022-07-28 22:19:04 -0500
commitf1d37de6ad5ffb2d88134e0a0847de78f7c8e67a (patch)
tree0463efe5577d482c48dff42e9a3fb66e9ef1804e
parent9d695bb88d220d451cf7e2c4369478149fc2d0cc (diff)
downloadaur-f1d37de6ad5ffb2d88134e0a0847de78f7c8e67a.tar.gz
update to 0.8.1
-rw-r--r--.SRCINFO6
-rw-r--r--CHANGELOG.md58
-rw-r--r--PKGBUILD4
3 files changed, 62 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2dbd44d97e23..d167ebf2ecfe 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = apollo-rover
pkgdesc = CLI for Apollo's suite of GraphQL developer productivity tools
- pkgver = 0.7.0
+ pkgver = 0.8.1
pkgrel = 1
url = https://github.com/apollographql/rover
install = rover.install
@@ -12,7 +12,7 @@ pkgbase = apollo-rover
depends = zlib
replaces = apollo-rover-fed2
options = !lto
- source = apollo-rover-0.7.0.tar.gz::https://github.com/apollographql/rover/archive/v0.7.0.tar.gz
- sha256sums = e8e271a084123feffac8c0a566402c0323cb7e1ea37f8c740b9fb883f23cad80
+ source = apollo-rover-0.8.1.tar.gz::https://github.com/apollographql/rover/archive/v0.8.1.tar.gz
+ sha256sums = 85ae6a9ca5c81f9b30cfbf56130dddad9b57e2fc895a0eccf27a88dd619ae905
pkgname = apollo-rover
diff --git a/CHANGELOG.md b/CHANGELOG.md
index 9c325d6805f0..4459ab4b68a3 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -18,6 +18,62 @@ This project adheres to [Semantic Versioning](https://semver.org/spec/v2.0.0.htm
## 📚 Documentation -->
+# [0.8.1] - 2022-07-28
+
+## 🐛 Fixes
+
+- **Fixes superfluous output in npm installer - @EverlastingBugstopper, #1200 fixes #1197 and #1198**
+
+ In 0.8.0, we released a fix for our npm installer that makes it compatible with yarn workspaces by reinstalling Rover if it doesn't exist. Unfortunately, that means that steps that rely on printing to stdout contained information about the installs in those invocations. This has been fixed.
+
+## 📚 Documentation
+
+- **Adds documentation for the async checks feature introduced in 0.8.1 - @EverlastingBugstopper, #1193**
+
+# [0.8.0] - 2022-07-27
+
+## 🚀 Features
+
+- **Add new commands to use asynchronous checks API - @Y-Guo, #1139**
+
+ If you want to kick off a check without waiting for it to complete you can provide the `--background` flag to `rover graph check` or `rover subgraph check`. This will start the check in Apollo Studio. If your GitHub repo integrates with the Apollo Studio GitHub App, the check status will be updated on your GitHub branch. Using this flag can save you time and money with your CI provider.
+
+- **Improved error messages and logs for filesysten read/write - @EverlastingBugstopper, #1183**
+
+ Start using the `saucer` create for file system read/writes. This will provide better errors than the ones provided by `std::fs` e.g. `permission denied os error (2)` by providing context about which file rover is trying to read/write to. Every read/write/other filesystem operation will now be included in the `--log info` output.
+
+## 🐛 Fixes
+
+- **Install rover before run if missing in npm package - @trevor-schneer, #1184 fixes #1178**
+
+- **Don't retry `400 Bad Request` errors - @EverlastingBugstopper, #1166**
+
+## 🛠 Maintenance
+
+- **Refactor command line argument parsing - @EverlastingBugstopper, #1155**
+
+- **Improve schema downloading for codegen, when building rover - @EverlastingBugstopper, #1166**
+
+- **Update rover to clap v3 - @EverlastingBugstopper, #1170 fixes #1165**
+
+- **Add Apollo Studio integration tests - @EverlastingBugstopper, #1188**
+
+ We now run integration tests against Apollo Studio's platform API as part of our release pipeline.
+
+## 📚 Documentation
+
+- **Update help message for `rover subgraph introspect` - @EverlastingBugstopper, #1169**
+
+ Previously the help message for `rover subgraph introspect` claimed to introspect from Apollo Studio Registry but it really introspects from a running subgraph endpoint.
+
+- **Add Jenkins CI/CD Documentation - @StephenBarlow, #1151**
+
+- **Update, restructure, and add missing docs for existing rover commands - @StephenBarlow, #1154, #1157**
+
+- **Update rover version in CI/CD docs - @rajington, #1177**
+
+- **Fix broken anchors for fetching schema - @tchupp, #1176**
+
# [0.7.0] - 2022-06-09
## 🚀 Features
@@ -57,7 +113,7 @@ This project adheres to [Semantic Versioning](https://semver.org/spec/v2.0.0.htm
## 🐛 Fixes
-- **Fixes Input Value Definition block string encoding for descriptions. - @lrlna, #1116 # fixes #1088**
+- **Fixes Input Value Definition block string encoding for descriptions. - @lrlna, #1116 fixes #1088**
Input values are now multilined when a description is present to allow for a more readable generated SDL.
diff --git a/PKGBUILD b/PKGBUILD
index a62a4524a0d1..e67432d8af7c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
pkgname=apollo-rover
-pkgver=0.7.0
+pkgver=0.8.1
pkgrel=1
pkgdesc="CLI for Apollo's suite of GraphQL developer productivity tools"
arch=('x86_64')
@@ -14,7 +14,7 @@ options=('!lto')
install=rover.install
changelog=CHANGELOG.md
source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
-sha256sums=('e8e271a084123feffac8c0a566402c0323cb7e1ea37f8c740b9fb883f23cad80')
+sha256sums=('85ae6a9ca5c81f9b30cfbf56130dddad9b57e2fc895a0eccf27a88dd619ae905')
prepare() {
cd "rover-$pkgver"