summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatMoul2023-01-14 21:55:02 +0100
committerMatMoul2023-01-14 21:55:02 +0100
commitf1dd5b85c6f7216e4d68686f5e5ea50f00afc1a4 (patch)
treeef836ae05902bbaf49043152be36d53aaa08c98a
parent707f2d8e8f8ed98951c9ed01e508285000d216b5 (diff)
downloadaur-f1dd5b85c6f7216e4d68686f5e5ea50f00afc1a4.tar.gz
Version 0.14.0-2
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD44
2 files changed, 22 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 79ecc00f8722..5c95e1ebb9eb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -3,16 +3,14 @@ pkgbase = octopi-notifier-qt5
pkgver = 0.14.0
pkgrel = 2
url = https://tintaescura.com/projects/octopi/
- arch = i686
- arch = x86_64
+ arch = any
license = GPL2
makedepends = qt5-tools
depends = octopi
- depends = libnotify
+ depends = knotifications
optdepends = xfce4-notifyd: for notifications in XFCE
provides = octopi-notifier
- conflicts = octopi-notifier-frameworks
- source = octopi-0.14.0-2.tar.gz::https://github.com/aarnt/octopi/archive/0a47127c711c20f9f8f4c42298a25992dbbf98b9.tar.gz
- sha256sums = 41cf58d9fd12143e34b75798cc65ad467aed69257c8e04a7b9cbee77ae01d133
+ source = octopi::https://github.com/aarnt/octopi/archive/refs/tags/v0.14.0.tar.gz
+ sha256sums = 9b548661807fe8eecc20726a4aefa25658c4ce1bf1bc8f51b54829809d76f12d
pkgname = octopi-notifier-qt5
diff --git a/PKGBUILD b/PKGBUILD
index 77ad0e92485c..3f7215bab6ce 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,41 +1,33 @@
-# Maintainer: MatMoul <matmoul@gmail.com>
+# Maintainer: MatMoul <matmoul at the google email domain which is .com>
-_pkggit=octopi
-_gitcommit=0a47127c711c20f9f8f4c42298a25992dbbf98b9
-_gitsha256='41cf58d9fd12143e34b75798cc65ad467aed69257c8e04a7b9cbee77ae01d133'
+_githubuser=aarnt
+_githubrepo=octopi
+_pkgtagname=v0.14.0
-pkgbase=octopi-notifier-qt5
-pkgname=('octopi-notifier-qt5')
+pkgname=octopi-notifier-qt5
pkgver=0.14.0
pkgrel=2
-pkgdesc="Notifier for Octopi using Qt5 libs"
-arch=('i686' 'x86_64')
+pkgdesc='Notifier for Octopi using Qt5 libs'
+arch=('any')
url="https://tintaescura.com/projects/octopi/"
license=('GPL2')
-depends=('octopi' 'libnotify')
+depends=('octopi' 'knotifications')
makedepends=('qt5-tools')
optdepends=('xfce4-notifyd: for notifications in XFCE')
provides=('octopi-notifier')
-conflicts=('octopi-notifier-frameworks')
-source=("octopi-${pkgver}-${pkgrel}.tar.gz::https://github.com/aarnt/octopi/archive/${_gitcommit}.tar.gz")
-sha256sums=(${_gitsha256})
-
-prepare() {
- cd "${srcdir}/${_pkggit}-${_gitcommit}"
-}
+source=("${_githubrepo}::https://github.com/${_githubuser}/${_githubrepo}/archive/refs/tags/${_pkgtagname}.tar.gz")
+sha256sums=('9b548661807fe8eecc20726a4aefa25658c4ce1bf1bc8f51b54829809d76f12d')
build() {
- cd "${srcdir}/${_pkggit}-${_gitcommit}"
-
- msg "Building octopi-notifier..."
- cd notifier
- qmake-qt5 PREFIX=/usr QMAKE_CFLAGS="${CFLAGS}" QMAKE_CXXFLAGS="${CXXFLAGS}" QMAKE_LFLAGS="${LDFLAGS}" octopi-notifier.pro
- make
+ cd "${_githubrepo}-${pkgver}"
+ msg "Building octopi-notifier..."
+ cd notifier
+ qmake-qt5 PREFIX=/usr QMAKE_CFLAGS="${CFLAGS}" QMAKE_CXXFLAGS="${CXXFLAGS}" QMAKE_LFLAGS="${LDFLAGS}" octopi-notifier.pro
+ make
}
package() {
- cd "${srcdir}/${_pkggit}-${_gitcommit}"
-
- cd notifier
- make INSTALL_ROOT="${pkgdir}" install
+ cd "${_githubrepo}-${pkgver}"
+ cd notifier
+ make INSTALL_ROOT="${pkgdir}" install
}