summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Rys2022-12-09 15:59:38 +0100
committerMartin Rys2022-12-09 15:59:38 +0100
commitf1e9162c4c2c5689d66b4ca3b1ef8e623676da76 (patch)
tree78a67476c8fb58607c06724a076ec077b7828240
parent731017c280d992319b4c955d3084afb136b129f8 (diff)
downloadaur-f1e9162c4c2c5689d66b4ca3b1ef8e623676da76.tar.gz
Fix version detection
-rw-r--r--PKGBUILD5
1 files changed, 4 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ad8a639828db..7d5e22e53b04 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=oauth2_proxy
pkgver=7.4.0
-pkgrel=2
+pkgrel=3
pkgdesc="A reverse proxy that provides authentication with Google, Github or other providers."
arch=('i686' 'x86_64')
url="https://github.com/oauth2-proxy/oauth2-proxy"
@@ -25,6 +25,9 @@ build() {
export GOPATH="$(pwd)/deps:$(realpath $(pwd)/..)"
cd github.com/oauth2-proxy/oauth2-proxy
+ # Default version variable to $pkgver instead of "undefined" as the buildtime version detection in the Makefile fails
+ sed -i "s,VERSION = \"undefined\",VERSION = \"${pkgver}\"," version.go
+
go build -o ../../../dist/oauth2-proxy -trimpath
}