summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarsten Teibes2023-12-03 00:43:46 +0100
committerCarsten Teibes2023-12-03 00:43:46 +0100
commitf1f587618558afd9ba38e009e8605a5e346680b8 (patch)
treedaeb537f6c5fe020b3593292cde4c2ac705f1aea
parente7a507a5f723acc54b8695052aca6f78493c977e (diff)
downloadaur-f1f587618558afd9ba38e009e8605a5e346680b8.tar.gz
[fix] build with gcc 10, deps
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD34
2 files changed, 19 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index db47188a9e8a..af808362eccb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = gngeo-git
pkgdesc = A portable command-line NeoGeo Emulator (development version)
pkgver = 0.8.r21.ged06739
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/pepone42/gngeo
install = gngeo-git.install
arch = i686
arch = x86_64
license = custom GPL
- makedepends = mercurial
+ makedepends = git
makedepends = glu
depends = zlib
depends = sdl
@@ -24,4 +24,3 @@ pkgbase = gngeo-git
makedepends_i686 = nasm
pkgname = gngeo-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 8ea2cad11fb4..46ca48702883 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,22 @@
# Maintainer: carstene1ns <arch carsten-teibes de> - http://git.io/ctPKG
-pkgname=gngeo-git
+_pkgname=gngeo
+pkgname=$_pkgname-git
pkgver=0.8.r21.ged06739
-pkgrel=1
+pkgrel=2
pkgdesc="A portable command-line NeoGeo Emulator (development version)"
arch=('i686' 'x86_64')
url="https://github.com/pepone42/gngeo"
license=('custom GPL')
depends=('zlib' 'sdl')
-makedepends=('mercurial' 'glu')
+makedepends=('git' 'glu')
makedepends_i686=('nasm')
optdepends=('libgl: OpenGL renderer backend')
-conflicts=("${pkgname%-*}")
-provides=("${pkgname%-*}")
+conflicts=("$_pkgname")
+provides=("$_pkgname")
replaces=("gngeo-hg")
install=$pkgname.install
-source=(${pkgname%-*}::"git+https://github.com/pepone42/gngeo.git#branch=gngeo"
+source=($_pkgname::"git+https://github.com/pepone42/gngeo.git#branch=gngeo"
"$pkgname.desktop"
"$pkgname.png")
sha256sums=('SKIP'
@@ -23,13 +24,13 @@ sha256sums=('SKIP'
'b543425d51bd669fe5081b0b89492f18163c292194ac2a4acff683ba2a60063e')
pkgver() {
- cd ${pkgname%-*}
+ cd $_pkgname
git describe --tags --long | sed 's/^gngeo_//;s/-/.r/;s/-/./'
}
prepare() {
- cd ${pkgname%-*}
+ cd $_pkgname
# change path
sed 's|games/lib|share|' -i sample_gngeorc
@@ -39,24 +40,23 @@ prepare() {
}
build() {
- cd ${pkgname%-*}
+ cd $_pkgname
./bootstrap
- ./configure --prefix=/usr
- # force single threaded build
- make -j1
+ ./configure --prefix=/usr CFLAGS="$CFLAGS -fcommon" # gcc 10 fix
+ make
}
package() {
- cd ${pkgname%-*}
+ cd $_pkgname
make DESTDIR="$pkgdir/" install
# install icon, .desktop, sample config and license file
- install -Dm644 ../$pkgname.png "$pkgdir"/usr/share/pixmaps/${pkgname%-*}.png
+ install -Dm644 ../$pkgname.png "$pkgdir"/usr/share/pixmaps/$_pkgname.png
install -Dm644 ../$pkgname.desktop "$pkgdir"/usr/share/applications/$pkgname.desktop
- install -Dm644 sample_gngeorc "$pkgdir"/usr/share/${pkgname%-*}/sample_gngeorc
- install -d "$pkgdir"/usr/share/doc/${pkgname%-*}
- install -m644 AUTHORS FAQ NEWS README TODO "$pkgdir"/usr/share/doc/${pkgname%-*}
+ install -Dm644 sample_gngeorc "$pkgdir"/usr/share/$_pkgname/sample_gngeorc
+ install -d "$pkgdir"/usr/share/doc/$_pkgname
+ install -m644 AUTHORS FAQ NEWS README TODO "$pkgdir"/usr/share/doc/$_pkgname
install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
}