summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRustam Aliyev2020-02-15 18:12:13 +0900
committerRustam Aliyev2020-02-15 18:12:13 +0900
commitf1fd990d3a94f63facf6a724c021d73ac2cba0fb (patch)
tree42ff40da3ce9f1dc48d21a129ca6e579cf57a1a4
downloadaur-f1fd990d3a94f63facf6a724c021d73ac2cba0fb.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--CHANGELOG.md93
-rw-r--r--PKGBUILD31
3 files changed, 142 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7d5ee44630f4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = pyflow
+ pkgdesc = An installation and dependency system for Python
+ pkgver = 0.2.4
+ pkgrel = 1
+ url = https://github.com/David-OConnor/pyflow
+ changelog = CHANGELOG.md
+ arch = x86_64
+ arch = i686
+ license = MIT
+ checkdepends = cargo
+ makedepends = cargo
+ depends = xz
+ source = https://github.com/ru5j4r0/aur/raw/master/pyflow/pyflow-0.2.4.tar.zst
+ validpgpkeys = B3D4420410BC16F84C358DF6AF36488D565A347A
+ b2sums = f627b528be505ff999385a50f840baae7fc1a1e88c29d20b11e548c9eaa6fc15cf115e678f4eed7cbda0153c46d54769b835ffc86d13401a0a43cdaaaa5e59fb
+
+pkgname = pyflow
+
diff --git a/CHANGELOG.md b/CHANGELOG.md
new file mode 100644
index 000000000000..5b0ab4348c31
--- /dev/null
+++ b/CHANGELOG.md
@@ -0,0 +1,93 @@
+# Changelog
+
+## v0.2.4
+- Fixed a bug where `pyflow script` was broken
+- Fixed a bug where `pyflow init` was broken
+- Fixed parsing `Pipfile`
+- `pyflow switch` now sets up the environment/dependencies with the new version
+- Fixed a bug where `bsd` specified as an OS on Pypi would cause a crash
+
+## v0.2.3
+- Fixed a potential conflict between the built-in `typing` module, and one on pypi
+- Now can parse deps with brackets listed in requirements
+- Now supports dependencies specified using `~=`. (Treat same as `~`)
+
+## v0.2.1
+- Running `pyflow install` is now no longer required; Running `pyflow`, `pyflow list` etc
+will now install dependencies as required from `pyproject.toml`.
+- `pyflow new` now asks for the Python version instead of using a default.
+- Now searches parent directories for `pyproject.toml`, if we can't find one
+in the current path.
+
+## v0.1.9
+- Can now parse subdependencies of `path` requirements from built-wheels
+- Fixed a bug where subdep contraints specified on multiple lines would
+cause resolution to fail
+- Fixed a bug parsing METADATA requirements that includes extras, but no version
+
+## v0.1.8
+- Fixed a bug in auto-filling name and email in `pyflow init` and `pyflow new`
+- Running `pyflow` alone in a directory without a `pyproject.toml` will now no
+longer attempt to initialize a project
+- Added support for specifying a build script
+- Treat `python_version` on `pypi` as a caret requirement, if specified like `3.6`.
+- Improved error messages
+
+## v0.1.7
+- Fixed bugs in `path` dependencies
+
+## v0.1.6
+- Added installation from local paths and Git repositories
+- Improved error messages and instructions
+
+## v0.1.5
+- Combined `author` and `author_email` cfg into one field, `authors`, which takes
+- a list. Populates automatically from git. `pyflow new` creates
+ a new git repository. (Breaking)
+- Fixed a bug with uninstalling packages that use non-standard naming conventions
+- Fixed a bug with installing on Mac
+- Fixed a bug uninstalling packages from the CLI
+
+## v0.1.4
+- Clear now lets the user choose which parts of the cache to clear
+- Fixed a bug with dev reqs
+- Fixed a bug with CLI-added deps editing `pyproject.toml`
+- Added `--dev` flag to `install`
+
+## v0.1.3
+- Added support for dev dependencies
+- Fixed a bug where dependencies weren't being set up with the `package` command
+
+## v0.1.2
+- Added support for installing Python on most Linux distros
+- Wheel is now installed directly, instead of with Pip; should only be dependent on
+pip now to install `twine`.
+- Now doesn't ask to choose between aliases pointing to the same Python install.
+- Fixed a bug related to creating `pyflow` directory
+- Fixed a bug in specifying package url with the `publish` command.
+
+
+## v0.1.1
+- Fixed a bug, where spaces could prevent console scripts from being installed
+- Fixed parsing pypi requirements that ommit parenthesis
+- Now uses `~/.local/share/pyflow` on Linux, `~\AppData\Roaming\pyflow` on Windows, and
+`~/Library/Application Support/pyflow` on Mac, instead of `~/.python-installs`
+
+## v0.1.0
+- Installing Python binaries now works correctly on Windows, Ubuntuā‰„18.4, and Debian
+- Running `pyflow` with no arguments now runs a Python REPL
+- Made error messages more detailed
+
+## v0.0.4
+- Renamed from `pypackage` to `pyflow`
+- Added support for running minimally-configured scripts
+- Implemented `pyflow switch` to change py versions. Improved related prompts
+- Misc API tweaks
+
+## v0.0.3
+- Now manages and installs Python as required
+- Stores downloaded packages in a global cache
+- Can run console scripts specified in `pyproject.toml` directly, instead of just
+ones installed by dependencies
+- `pypackage reset` now cleans up the lock file
+- Misc tweaks and bugfixes
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a460d643b4b4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Rustam Aliyev <ru5j4r0@google.com>
+pkgname=pyflow
+pkgver=0.2.4
+pkgrel=1
+pkgdesc="An installation and dependency system for Python"
+arch=('x86_64' 'i686')
+url="https://github.com/David-OConnor/pyflow"
+license=('MIT')
+depends=('xz')
+makedepends=('cargo')
+checkdepends=('cargo')
+changelog=CHANGELOG.md
+source=("https://github.com/ru5j4r0/aur/raw/master/pyflow/$pkgname-$pkgver.tar.zst")
+b2sums=(f627b528be505ff999385a50f840baae7fc1a1e88c29d20b11e548c9eaa6fc15cf115e678f4eed7cbda0153c46d54769b835ffc86d13401a0a43cdaaaa5e59fb)
+validpgpkeys=(B3D4420410BC16F84C358DF6AF36488D565A347A)
+
+build() {
+ cd "$pkgname-$pkgver"
+ cargo build --release --locked
+}
+
+check() {
+ cd "$pkgname-$pkgver"
+ cargo test --release --locked
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -Dt "$pkgdir/usr/bin" target/release/pyflow
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}