summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVincent Grande2021-03-02 13:24:55 -0500
committerVincent Grande2021-03-02 13:24:55 -0500
commitf201b52ff38e4db634dce58651de2ac138a1eab8 (patch)
tree842c6b79236384109bae29137b1e39dbc23ca50a
parent4a04968967d8312357ebc04957d50cc1c1d580bb (diff)
downloadaur-f201b52ff38e4db634dce58651de2ac138a1eab8.tar.gz
use meson
-rw-r--r--.SRCINFO6
-rwxr-xr-xPKGBUILD30
2 files changed, 23 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0df4642c4b27..a56fafc640c5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -19,9 +19,13 @@ pkgbase = lib32-fontconfig-git
provides = lib32-fontconfig
conflicts = lib32-fontconfig
source = git+https://gitlab.freedesktop.org/fontconfig/fontconfig
+ source = https://gitlab.freedesktop.org/fontconfig/fontconfig/-/merge_requests/172.patch
+ source = https://gitlab.freedesktop.org/fontconfig/fontconfig/-/merge_requests/138.patch
source = fontconfig-32.hook
sha256sums = SKIP
- sha256sums = d97c0c5b88023da5a2acf64cf560265390a9365305c43b8e86b4f89348e727b3
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
pkgname = lib32-fontconfig-git
diff --git a/PKGBUILD b/PKGBUILD
index e44dde58ea6b..38b6d4ea1071 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,11 +16,14 @@ conflicts=(lib32-fontconfig)
depends=(lib32-expat lib32-freetype2 $_pkgbasename)
makedepends=(git autoconf-archive gperf python-lxml python-six lib32-json-c)
install=lib32-fontconfig.install
-#_commit=5f5ec5676c61b9773026a9335c9b0dfa73a73353 # master
source=("git+https://gitlab.freedesktop.org/fontconfig/fontconfig"
+ "https://gitlab.freedesktop.org/fontconfig/fontconfig/-/merge_requests/172.patch"
+ "https://gitlab.freedesktop.org/fontconfig/fontconfig/-/merge_requests/138.patch"
fontconfig-32.hook)
sha256sums=('SKIP'
- 'd97c0c5b88023da5a2acf64cf560265390a9365305c43b8e86b4f89348e727b3')
+ 'SKIP'
+ 'SKIP'
+ 'SKIP')
# a nice page to test font matching:
# http://zipcon.net/~swhite/docs/computers/browsers/fonttest.html
@@ -33,7 +36,9 @@ pkgver() {
prepare() {
cd $_pkgbasename
- NOCONFIGURE=1 ./autogen.sh
+
+ patch -Np1 -i ../138.patch
+ patch -Np1 -i ../172.patch
}
build() {
@@ -43,15 +48,15 @@ build() {
export CXX="g++ -m32"
export PKG_CONFIG="i686-pc-linux-gnu-pkg-config"
- ./configure --prefix=/usr \
+ arch-meson fontconfig build \
--libdir=/usr/lib32 \
- --sysconfdir=/etc \
- --with-templatedir=/etc/fonts/conf.avail \
- --with-xmldir=/etc/fonts \
- --localstatedir=/var \
- --disable-static \
- --with-default-fonts=/usr/share/fonts \
- --with-add-fonts=/usr/local/share/fonts
+ -D doc=disabled \
+ -D doc-txt=disabled \
+ -D doc-man=disabled \
+ -D doc-pdf=disabled \
+ -D doc-html=disabled \
+ -D tests=disabled
+ ninja $NINJAFLAGS -C build
make
}
@@ -62,7 +67,8 @@ build() {
package() {
cd $_pkgbasename
- make DESTDIR="$pkgdir" install
+
+ DESTDIR="$pkgdir" ninja $NINJAFLAGS -C build install
rm -r "$pkgdir"/{etc,usr/{include,share}}
find "$pkgdir/usr/bin" -not -type d -not -name fc-cache -delete