summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2020-08-07 21:31:13 +0200
committerhaawda2020-08-07 21:31:13 +0200
commitf20dc06573ce26c9679682d13ed6794b042226c2 (patch)
tree1fdd656cf3808273186b28f5efa2c99cb89413f5
parent91ee77112df7616cc2da5cae29565475eedc1e18 (diff)
downloadaur-f20dc06573ce26c9679682d13ed6794b042226c2.tar.gz
use git submodules the Arch Way, fix dependencies
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD15
2 files changed, 18 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4ed172daca42..6622143a6bb4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = cutemarked-git
pkgdesc = Qt Markdown Editor
pkgver = 20200625.r910
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/Waqar144/CuteMarkEd-NG
arch = i686
arch = x86_64
@@ -9,12 +9,15 @@ pkgbase = cutemarked-git
makedepends = git
makedepends = qt5-tools
depends = qt5-webengine
- depends = hunspell
- depends = discount
- depends = hicolor-icon-theme
provides = cutemarked
conflicts = cutemarked
source = git+https://github.com/Waqar144/CuteMarkEd-NG.git
+ source = git+https://github.com/hunspell/hunspell.git
+ source = git+https://github.com/mity/md4c
+ source = https://github.com/pbek/qmarkdowntextedit
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
md5sums = SKIP
pkgname = cutemarked-git
diff --git a/PKGBUILD b/PKGBUILD
index 17ca06ba88d6..3889ddba8426 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,17 +4,21 @@
_gitname=CuteMarkEd-NG
pkgname=cutemarked-git
pkgver=20200625.r910
-pkgrel=1
+pkgrel=2
pkgdesc="Qt Markdown Editor"
url="https://github.com/Waqar144/${_gitname}"
arch=('i686' 'x86_64')
license=('GPL2')
-depends=('qt5-webengine' 'hunspell' 'discount' 'hicolor-icon-theme')
+depends=('qt5-webengine')
makedepends=('git' 'qt5-tools')
provides=('cutemarked')
conflicts=('cutemarked')
-source=("git+$url.git")
-md5sums=('SKIP')
+source=("git+$url.git"
+ "git+https://github.com/hunspell/hunspell.git"
+ "git+https://github.com/mity/md4c"
+ "https://github.com/pbek/qmarkdowntextedit"
+ )
+md5sums=('SKIP' 'SKIP' 'SKIP' 'SKIP')
pkgver() {
cd $_gitname
@@ -24,6 +28,9 @@ pkgver() {
prepare() {
cd $_gitname
git submodule init
+ for __submodule in hunspell md4c qmarkdowntextedit
+ do git config submodule.${__submodule}.url "$srcdir"/${_gitname}/3rdparty/${__submodule}
+ done
git submodule update
}