summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Arndt2024-02-13 18:52:33 +0100
committerChristopher Arndt2024-02-24 16:45:10 +0100
commitf215754ecaf431c4b4be05b80f121d63f5cfa1dc (patch)
tree9c1b473ac3cd8f4fd700a5ab9d0ba1be7faee77d
parent10e5dfb5ac3ffc1493bc80e742aad0f2873b4f24 (diff)
downloadaur-f215754ecaf431c4b4be05b80f121d63f5cfa1dc.tar.gz
Update sub-modules, pkgdesc and license
Signed-off-by: Christopher Arndt <chris@chrisarndt.de>
-rw-r--r--.SRCINFO10
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD32
3 files changed, 35 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 552305284ccc..783db9ca9e56 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
pkgbase = guitarix.vst-git
- pkgdesc = A virtual versatile amplification for Jack/Linux - vst3 wrapper
- pkgver = v0.1.r1.gacbdd19
+ pkgdesc = A versatile (guitar) amplifiier VST3 plugin (git version)
+ pkgver = v0.2.r0.g821480e
pkgrel = 1
url = https://github.com/brummer10/guitarix.vst
arch = x86_64
groups = vst3-plugins
groups = pro-audio
- license = GPL3
+ license = GPL-3.0-or-later
makedepends = git
makedepends = boost
makedepends = eigen
@@ -35,6 +35,10 @@ pkgbase = guitarix.vst-git
conflicts = guitarix.vst
source = guitarix.vst::git+https://github.com/brummer10/guitarix.vst
source = guitarix::git+https://github.com/brummer10/guitarix.git
+ source = NAM::git+https://github.com/sdatkinson/NeuralAmpModelerCore.git
+ source = eigen::git+https://gitlab.com/libeigen/eigen.git
+ sha256sums = SKIP
+ sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..403a910dbc61
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+pkg/
+src/
+NAM/
+eigen/
+guitarix/
+guitarix.vst/
+guitarix.vst-git-*.pkg.tar.*
diff --git a/PKGBUILD b/PKGBUILD
index 8a7e42ca64b7..6e330cd17e45 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,12 +3,12 @@
_pkgname=guitarix.vst
pkgname=$_pkgname-git
-pkgver=v0.1.r1.gacbdd19
+pkgver=v0.2.r0.g821480e
pkgrel=1
-pkgdesc='A virtual versatile amplification for Jack/Linux - vst3 wrapper'
+pkgdesc='A versatile (guitar) amplifiier VST3 plugin (git version)'
arch=(x86_64)
url='https://github.com/brummer10/guitarix.vst'
-license=(GPL3)
+license=(GPL-3.0-or-later)
groups=(vst3-plugins pro-audio)
depends=(alsa-lib curl gcc-libs glib2 glibc libsigc++ libsndfile lilv fftw freetype2 glibmm avahi)
makedepends=(git boost eigen gperf intltool lv2 waf sassc pkgconfig webkit2gtk)
@@ -19,9 +19,11 @@ optdepends=(
provides=($_pkgname)
conflicts=($_pkgname)
source=("$_pkgname::git+https://github.com/brummer10/guitarix.vst"
- 'guitarix::git+https://github.com/brummer10/guitarix.git')
-sha256sums=('SKIP' 'SKIP')
-
+ 'guitarix::git+https://github.com/brummer10/guitarix.git'
+ 'NAM::git+https://github.com/sdatkinson/NeuralAmpModelerCore.git'
+ 'eigen::git+https://gitlab.com/libeigen/eigen.git')
+sha256sums=('SKIP' 'SKIP' 'SKIP' 'SKIP')
+
pkgver() {
cd $_pkgname
(
@@ -30,19 +32,27 @@ pkgver() {
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
)
}
-
+
prepare() {
cd $_pkgname
- git submodule init
+ git submodule init guitarix
git submodule set-url guitarix "$srcdir"/guitarix
- git -c protocol.file.allow=always submodule update
+ git -c protocol.file.allow=always submodule update guitarix
+ cd guitarix
+ git submodule init trunk/src/NAM/NeuralAmpModelerCore
+ git submodule set-url trunk/src/NAM/NeuralAmpModelerCore "$srcdir"/NAM
+ git -c protocol.file.allow=always submodule update trunk/src/NAM/NeuralAmpModelerCore
+ cd trunk/src/NAM/NeuralAmpModelerCore
+ git submodule init Dependencies/eigen
+ git submodule set-url Dependencies/eigen "$srcdir"/eigen
+ git -c protocol.file.allow=always submodule update Dependencies/eigen
}
-
+
build() {
cd $_pkgname
make
}
-
+
package() {
cd $_pkgname
make JUCE_VST3DESTDIR="$pkgdir"/usr/lib/vst3 install