summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBen Edwards2018-05-07 21:11:27 +0100
committerBen Edwards2018-05-07 21:11:27 +0100
commitf2171b81fef3425a39d2123154ca855e4dc4dc23 (patch)
treeb41fa680f6796ab275c621c24ed431bd32b4dba8
parent26dd3867a72b2ff0b44e2bb9c6c96dc28d67f6d9 (diff)
downloadaur-f2171b81fef3425a39d2123154ca855e4dc4dc23.tar.gz
Update to 3.4.0
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD14
2 files changed, 14 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cd7623024842..850b6fbb9ae7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,18 @@
pkgbase = web3j
pkgdesc = A lightweight, reactive, type safe Java and Android library for integrating with nodes on Ethereum blockchains
- pkgver = 3.3.1
- pkgrel = 2
+ pkgver = 3.4.0
+ pkgrel = 1
url = https://web3j.io/
arch = any
license = Apache
depends = java-runtime>=8
source = web3j
- source = https://github.com/web3j/web3j/releases/download/v3.3.1/web3j-3.3.1.tar
- source = https://github.com/web3j/web3j/releases/download/v3.3.1/web3j-3.3.1.tar.asc
+ source = https://github.com/web3j/web3j/releases/download/v3.4.0/web3j-3.4.0.tar
+ source = https://github.com/web3j/web3j/releases/download/v3.4.0/web3j-3.4.0.tar.asc
validpgpkeys = 99854D26AD9C565C34BCE2471295E078F64311DB
- md5sums = 414fe48c9297fae26241a7b3acefe349
- md5sums = 61d86dfbb48ddc02146029f03122b024
- md5sums = SKIP
+ sha256sums = 410a2c96c3dfcf1db1a3db0de346e25334b7b8b817bece714559845f21a65a57
+ sha256sums = 7c7d46c5eaf71f42fd74e57704b9e93bfc239edf9743f9fc3809f398bc2572ae
+ sha256sums = SKIP
pkgname = web3j
diff --git a/PKGBUILD b/PKGBUILD
index e6272c5b516e..f708e00e2f2d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,18 @@
# Maintainer: Your Name <ben@artfuldodge.io>
pkgname=web3j
-pkgver=3.3.1
-pkgrel=2
+pkgver=3.4.0
+pkgrel=1
pkgdesc='A lightweight, reactive, type safe Java and Android library for integrating with nodes on Ethereum blockchains'
arch=('any')
url='https://web3j.io/'
license=('Apache')
depends=('java-runtime>=8')
source=('web3j'
- 'https://github.com/web3j/web3j/releases/download/v3.3.1/web3j-3.3.1.tar'
- 'https://github.com/web3j/web3j/releases/download/v3.3.1/web3j-3.3.1.tar.asc')
-md5sums=('414fe48c9297fae26241a7b3acefe349'
- '61d86dfbb48ddc02146029f03122b024'
- 'SKIP')
+ "https://github.com/web3j/web3j/releases/download/v${pkgver}/web3j-${pkgver}.tar"
+ "https://github.com/web3j/web3j/releases/download/v${pkgver}/web3j-${pkgver}.tar.asc")
+sha256sums=('410a2c96c3dfcf1db1a3db0de346e25334b7b8b817bece714559845f21a65a57'
+ '7c7d46c5eaf71f42fd74e57704b9e93bfc239edf9743f9fc3809f398bc2572ae'
+ 'SKIP')
validpgpkeys=('99854D26AD9C565C34BCE2471295E078F64311DB')
package() {
cd "$pkgname-$pkgver"